Download

[Release] ADK Launcher

MOST FEATURES ARE CURRENTLY BROKEN DUE TO RECENT CHANGES IN THE EDITOR, A FULL REWRITE WITH NEW FUNCTIONALITY IS IN DEVELOPMENT

8934189fd471db202e2033816d851c6ee33fd2fd.png

What is it?
The ADKLauncher is a tool for managing your mods, and providing an alternative to the built-in cooking and publishing tools.

What does it do?
Without ever opening the development kit the launcher can:

  • Cook your mods
  • Upload and update your mods to the workshop
  • Verify your development files
  • Force launch the game with your mod loaded

What is it going to do?
Planned features include:

  • Automatic updating of ADK binaries
  • Automatic backup of mod project files.
  • Full interaction with your published mods on the workshop
  • Done! The ability to only cook your mod for Windows, for quick test runs in-game.

Where do I download it?
You can download the launcher from here:
http://creations.thatguynex.com/ADKLauncher.rar

I don’t like downloading random executables.
Good for you, the program is made with a scripting language called AutoIt, you can download the compiler for free. You can find the current source code for the launcher here:
http://creations.thatguynex.com/ADKLauncher/ADKLauncher.au3
http://creations.thatguynex.com/ADKLauncher/update.au3

But how do I use it?

Installation

  1. Download the launcher from the link above and the contants to their own folder.
  2. Run ADKLauncher.exe
  3. It should notify you that it is your first time running it, and it will ask you to fill out your settings.
  4. Fill out all options, making sure to set the ADK and Game paths to the correct folders.
  5. Select an option on the main menu and off you go!

Cooking a mod

  1. On the main menu select the “Cook Mod” option.
  2. A new window should appear with more options.
  3. Select your mod from the drop down selection and “Maps To Cook” field should populate with all the map files in your mod.
  4. Select the maps that you want to be cooked here, all of them should be selected by default.
  5. Hit start cook and grab a cup of coffee.

Uploading a mod

  1. On the main menu select the “Upload Manager” option.
  2. A new window should appear with more options.
  3. Select your mod from the list at the top to start, and then fill out the rest of the fields as required. For mods that have already been uploaded through the Launcher they should be filled in for you.
  4. Hit upload and watch it be processed and uploaded.

Force loading a mod

  1. First cook your mod if you have not already.
  2. On the main menu select the desired mod from the dropdown at the bottom of the window and hit “Run Mod”.
  3. A new window should appear with a list of the maps in your mod, select the one you wish to load and hit the “Run” button.

Updates

V 0.924

  • Various hotfixes detailed in this thread.

V 0.92
[LIST]

  • Added the ability to force run mod in a dedicated server/client configuration.
  • Added the ability to run mod as a stacked mod (stacked onto the base game).
  • Random bug fixes

V 0.91

  • Added the ability to cook Linux and Windows seperately.
  • Added much more verbose logging
  • Fixed a bug with verifying ADK files
  • Fixed a bug with Steam credentials being loaded correctly.
  • Fixed a few other assorted small bugs.

DISCLAIMER
This program is still what I would consider Alpha, especially since I wrote it entirely this morning. Please report any bugs or issues you run into here in the thread and I will try to roll out patches as best as I can.

Nice job! I’m about to crash for the night, but I’m excited to take this puppy for a test run tomorrow and report back with my findings :smiley:

  • Sinari

This is fantastic, great job Nex.

I’ll give it a whir now. Will post if I find anything.

-> The cooking window is a tad delayed when initiated (This could just be a placebo)
-> Linux is on by default with it’s toggle in settings for now (feature not added yet), however Nex, perhaps a window after clicking “cook” suggesting linux or windows cooking be turned off as a one-time reminder?
-> Upload works great!

Force loading does what exactly?

So far so good man, nice work!

Great little utility!
Even got a sticky on the forum, look at you go. :wink:

Thank you very much for the support guys! I found a few more bugs which have fixed, and I also added support for enabling/disabling Linux and Windows builds individually. Once I finish updating my ADK so I can fully test the new version I will roll it out as an automatic update for you guys.

Edit: To expand on what the force loading does, it migrates a cooked mod folder to your Ark game directory, and then runs ShooterGame.exe with the correct parameters for loading the mod directly. The point is that it allows you to run your mods in the actual game for testing, without having to go through the Workshop.

Edit: I rolled this out a while ago, restarting the launcher will cause it to check for updates.

Awesome thanks for this Nex, congrats on the sticky

I pushed out another update which adds support for testing on a dedicated server and as a stacked mod. Let me know if you run into any issues with the stacked mod option, I haven’t played around with them much myself yet so I wasn’t able to test as well as I would like.

Would you mind adding the change notes field when using your tool to upload mods? Also, I get the error


Windows cannot find 'C:\Program'. Make sure you typed the name correctly, and then try again.

when attempting to launch the devkit through your tool. It is likely because the directory for my devkit has a space in Program Files so it shortens “C:\Program Files (x86)\Steam\steamapps\common\ARKDevKit\arkdevkitlaunch.bat” to “C:\Program”.

Can confirm, my path contains a space too and I get the same error

Sorry I didn’t see this sooner, I am out of town today. I compiled a quick hot fix which should do the trick, let me know if you still have issues.

Seems for me, no matter what I do it always assigns a new steam workshop ID. First I select folder, empty ID. Upload. Success. Go back to Upload. ID is filled in correctly. Press Upload, new ID. What am I doing wrong? I am publishing to friends only at the moment

Still having issues Capture.JPG 4fb620f032b1565619bf63526185cfbe11ca0601.jpeg

You appear to be missing files for your ADK, try verifying your files and reinstalling the custom binaries.

Restart and try again now. This is what I get for using free range test monkeys.

Yeah, can’t update mods with this tool. Tried restarting, tried uploading again and again, always end up with a new item. Any way to force update a mod or am I stuck till they update the devkit?

Yep, same here. Can’t update existing. Without this feature, the tool has no use for me.

Just to give everyone an update here, I am waiting for v200 to settle before I start making more changes. I want to see exactly what role the launcher will be best off filling with the radical changes we are seeing in how projects are handled, and then I will likely do a full rewrite to get things to where I want them.

Awesome work so far man!!! I look forward to seeing the next iteration!

any chance of getting this re - uploaded all 3 links are dead now