Relative Transform is world?


I might be tired and done a stupid mistake somewhere here, but I can’t wrap my head around what it could possibly be…
Right now this seems to me like it should work, but it’s giving me very confusing results.

Here is the blueprint in question being run once

And here is the printed result of the WORLD POSITIONS of each of the components


I’d be happy for any assistance at this point. Thank you!

Thanks! This seems to have solved part of the problem! This gave me a result that seemed much closer to what I was expecting in the first place. However i was still expecting the offset to be respected.

I’m assuming you meant something like this


And here is the printed result. As you can see it now appears to nearly match the parent, but seems to not take into account the -3000 relative location offset i set. Which should be around 400 world units below the parent.


But again, thank you for the swift response. I’m certain I can work with this result better than the first one!
I’ll update if i run into more problems related to this!

Have you tried inverse transform to see if it corrects to world?

That does work but I actuly meant was to put an inverse transform in the printed vector 3 so yo can see what’s going on but this works. Maybe swap the inverse transform for the world location of you attachment socket if it wants a ws cord.

Yea I noticed after, that you wrote Inverse and not Invert. But I managed to make it work with this. Thanks!