Reinstalling UE to another drive broke it, please help

I recently realized I had accidentally installed UE 4.25 on my external hdd which was causing it to run slowly so I tried to move it but couldn’t because Epic Games Launcher doesn’t believe in letting users do that apparently. I then completely uninstalled Epic Games Launcher and Reinstalled it then redownloaded UE 4.25 and now if I create a project and then try to create an empty script file it fails to compile it with this log message:

Running C:/Program Files/Epic
-projectfiles -project=“C:/Users/depre/Documents/Unreal
-game -rocket -progress Discovering modules, targets and source code for
project… While compiling C:\Program
error CS0042: Unexpected error
creating debug information file
‘c:\Program Files\Epic
– 'c:\Program Files\Epic Games\UE_4.25\Engine\Intermediate\Build\BuildRules\UE4Rules.pdb:
Access is denied. ERROR: Unable to compile source files.

If I then exit the project and try to relaunch it then I get this message:

The following modules are missing or
built with a different engine version:
MyProject Would you like to rebuild them now? Yes
--------> MyProject could not be compiled. Try rebuilding from source

I have tried uninstalling and reinstalling all the Visual Studio 2019 files that I’m told I need to compile my UE files. I even went into [UE4RootLocation]\Engine\Extras\Redist\en-us] and reinstalled that as well. I even found the VS 2019 extension in one of the folders and installed that. I don’t understand what’s going on…Anyone know what the deal is?


I figured it out, just as soon as I posted this I noticed the “Access is denied.” portion of the error…I had to find the UnrealEditor.exe and set it to run as an Administrator…don’t know why that would be a thing, but it fixed it.

1 Like

Perfect solution for me! Thanks for replying with it.

Glad it helped

For the security paranoid among us it appears you only have to do this once and then you can revoke administrator permissions from the program.