Reimport Skeletal Mesh not thorough

Whenever I make a change to my skeletal mesh, it’s not always taking the changes when I reimport the asset.

For instance, I created a character using a similar skeleton to the UE4 guy but overlooked a few bone orientations. Mainly, the root bone itself was oriented differently, causing my character to rotate on his side during the animations.

I fixed it in max and exported it back out.

Reimporting it into UE4 succeeds no problem, but I get a character with the same root bone problem problem. It doesn’t reimport some aspect of the fixed FBX.

Renaming the FBX to (2) and importing that fresh onto the same skeleton as a duplicate asset fixes the issue and the changes show up just fine.

I should note I’ve seen this same thing happen with static meshes in conjunction with a 2nd UV set. Though unreliable it seems. Reimporting sometimes seems to overwrite the UVs. It’s not that it’s set to auto-generate lightmap UVs or anything, I shut that off. I reimport, see the same UVs. I bring in a 2nd copy of the mesh and I get new UVs.

It’s something missing in reimport for sure.

Hey Hitpawz,

Would you mind sending me two fbx files that reproduce this issue? I can’t seem to get this on my end. You can put them in two separate folders so they’re named the same and then zip those folders together.

If you’d prefer to send them privately, you can PM me a download link on the forums.

-Matt W.

Hey Matt,

Well this is embarrassing but I too can’t replicate it right now. I’ll be sure to set aside a copy of any assets I create that do show the issue and get a hold of you, but let’s mark this solved for now. I don’t know what’s up yet, but a new project is fine. The project I keep seeing the problem in has literally been converted up the ladder since 4.1 so I’m a little weary I’ll discover the cause and I’ve already fixed it all.

Sorry for the bother, I know you spent time testing.

Hey Hitpawz,

It’s no bother! Just part of the job. Just respond here when you track down a bugged asset and it’ll pop back up in my queue.

-Matt W.