Reimport not working?

Hey there reader!

important info: i’m using a customized version of the engine from my work

i’m building a turntable in unreal to show my new models, but somehow i have a problem with reimporting.
When i make a model, like a crate, and make some changes to it, export to .fbx (overwriting my imported file) and reimport in UE4 (rightclicking in CB> reimport). the logg tells me it was a succesfull reimport, but when checking my model, nothing changed.
i also tried exporting a total different model (a cone or something) over the .fbx of the crate, and when reimporting it again. but the crate stays a crate and does not change to a cone.

i have also tried other stuff like deleting the model, saving, restart engine, and importing it again, but everything fails.
i have read that it has something to do with cache files. does anyone know where they are?


It is not a solution, but when something like this happens to me, I go the windows folder and past the mesh there. When I open the project again the engine does the import process, always works for me…

It doesn´t solve the bug, but you may try it to keep working in your project until they fix it. Good luck

Still happening in 4.23. =(

The first thing I would check is to ensure that the File path is going to your model. This can be found by hovering over you SM and reading the “Source File” link.

I once had in issue where my SM was linked to a back-up FBX I had created instead of my most up to date one. And each time I re-imported, it was updating from my old back-up, not my new one. This can also happen if you move your FBX to a different folder after having imported it prior.

The best way to test this is to drag and drop your updated FBX from your files on to your one in the content browser. If they are indeed the same file, it will automatically re-import (and in your case, hopefully update it). If they don’t match it should import it separately and link the mesh to your new location. You should then be able to delete the old copy, and select your new mesh when it prompts you to “Replace References”.