Reimport for animation sequence does not respect "Use Default Sample Rate" checkbox

I’m not sure if reimport is supposed to reuse the settings used for the actual import, but if that is the case there seems to be a bug.

I am making an animation for a pose assets by creating poses on every frame. When I import that animation with “Use Default Sample Rate” I get a frame for each pose which is what I want.

When I change the animation and reimport it the frame number changes. For example if the correct version had 11 frames the new reimported version has 8 frames which messes up the pose asset since the animation is not aligned to the frames.

After reimporting I can manually import and replace the file and it has 11 frames again. Shouldn’t the manually imported file and the reimported version be the same?

Hi cyaoeu,

If you keyed a pose on every frame, you shouldn’t even need UseDefaultSampleRate enabled in the first place. This sounds more like an Animation length issue. Could also be that the frame rate in your DCC is not set to 30 if UseDefaultSampleRate is becoming an issue.

I just did a test with 5 frames and 3 frames (with and without UseDefaultSampleRate) and it reimported and trimmed to 3 frames successfully.

Could you provide some more details and perhaps two sample fbx files (11 frame and 8 frame)?

-Matt W.

I’m using Blender. My frame rate is set to 30 and I tested the .fbx file in Houdini too, in both Blender and Houdini when imported as an .fbx file the frame rate changed to 30 and the animation was correct.

When imported to UE4 the animation is shorter for some reason unless imported with the default sample rate setting. It is only shorter in frames though, the time the animation plays stays the same (which is pretty weird).

I guess there’s some bug somewhere in either UE4 or Blender, but it wouldn’t matter much if the default sample rate checkbox wasn’t unticked during reimport. Even now it’s not a big deal if you reimport manually (import and overwrite assets) instead of doing the right click import.
link text

This is not the 11/8 frame example but you should be able to see a difference when importing it using the sample rate checkbox and when not using it.

Hey cyaoeu,

I went ahead and entered UE-40752 for the frame count issue.

As far as the reimport issue, you should see an “Import Settings” section when you open the animation in Persona. You should be able to double check that everything is as you want it for each animation. These are the settings that are used on reimport. I haven’t encountered a situation where I enabled “Use Default Sample Rate” on import, but it was disabled in those settings. Are you sure you didn’t accidentally disable it in the details panel?

-Matt W.

I’m pretty sure I didn’t disable it in that panel. However reimporting other animations worked fine so I experimented a bit to find the cause and noticed that the Import Settings didn’t change when replacing an animation by importing the file again and choosing new settings. I thought these were linked.

So probably what I did was import the file without Use Default Sample Rate, replace it by importing it again with Use Default Sample Rate ticked, then reimporting it which reimported the file using the original settings (without Use Default Sample Rate).

I’m not sure this is a bug but it seems pretty strange to me that the import settings for the asset don’t actually update when you replace the file by reimporting it one more time and you have changed some settings.

Anyway if you’re careful when importing the asset for the first time or even if you mess it up if you correct the Import Settings this shouldn’t be an issue. Thanks!

As a sidenote, couldn’t there be an actual button for reimporting the animation in Persona? (like for the mesh)

Hey cyaoeu,

I did some testing and found that the reimport issue no longer occurs in 4.15. For the time being, I’d definitely recommend reimporting by overwriting in 4.14.

Also, I added UE-41027 for the reimport button on animations.

-Matt W.