Reimport FBX Model Doesn't Work

I have an FBX model (FBX 2014 binary) that was exported from Maya LT 2015. It’s just a simple cube with a texture. I can import it into UE4 4.7.2 with no problem the first time. However, reimporting does not work. I right-click the model in the content browser, and choose reimport. The model does not change, and the output log gives an error, but the editor claims the import was successful. The log says this:

LogEditorFactories: Performing atomic reimport of [G:/../../../Eternal/Media/Maya/FBX/TestModel.fbx]
LogFbx:Error: Call to FbxImporter::Initialize() failed.
LogFbx:Warning: Error returned: Unexpected file type
LogEditorFactories:Warning: -- import failed

To be more specific, it will NOT work if the model file is on my G:\ drive, but DOES work if the model is on the C:\ drive. The file that doesn’t work is at:


The file that does work is at:


My project files are here:


My UE4 engine installation is at:

G:\Program Files\Epic Games\4.7

From my testing (and my investigating at the engine source code), this appears to be a problem between absolute paths and a bug in the relative path creation. See that the file that reimports has an absolute path, while the broken reimport references a faulty relative path.

See the log above that errors out with this (incorrect) path:


When the file is really at this path:


There are a few issues here. The main bug is that the path is wrong, and thus the file can never be reimported. The work around is to place the fbx files in a working drive (in my case C:) but this can be inconvenient (I use a smaller SSD for my main drive and thus want to store assets on a larger drive).

Secondly, the editor erroneously states that the import was successful, even while the output log shows an error, and the model is not updated.

Thirdly, I’d like to request a option to always use absolute paths for imported assets. This would at least be a quick workaround if the core bug will take too long to fix. Obviously it’s not the ultimate solution, but may be helpful to some people.

I’m on Windows 8.1 64-bit, Unreal Engine 4.7.2

Intel i7-5960X @ 3.0GHz | Asus X99-Deluxe | EVGA GTX 980 x 3 | Corsair Vengeance LPX 32GB DDR4 | Samsung 840 Pro 512GB | WD Black 4TB x 2 | Corsair Obsidian 550D | Corsair Hydro H55 | Corsair AX1500i | Asus Rog Swift PG278Q x 3 | Nvidia 3D Vision 2

Hey cybereality -

Thank you for your report. We are looking into this issue currently and attempting to reproduce the issue internally. As soon as I am able to test and I get results I will post back here.

Thank You Again -

Eric Ketchum

Hey cybereality -

I was able to reproduce this issue and have escalated it to our engineers for further investigation, for reference UE-11538. As we continue the investigation and work toward a solution I will keep you informed here.

Thank You

Eric Ketchum

Hello, I was wondering if there was any progress on this issue? It is extremely detrimental to my workflow!

Opening a mesh from the content browser and using the menu Mesh → View Source highlights the resource in Windows Explorer successfully.

Source file path: …/…/…/…/…/…/Projects/Cleaner/Blends/Outdoors1/elevatorplatform_station.fbx



D:\Programs\Epic Games\4.6\Engine\Binaries\Win64

Given all of the above, if I start in the engine directory and CD to the source file dir, it’s successful (meaning the correct number of “…/” exist). And also notice my project, Unreal installation, and FBX file are all on the same drive (D:/). This issue might be separate from the one in the original post.

I converted a copy of this project in place to 4.7.6 and the problem exists in that version as well.

Hi minderaser -

We are currently still actively working on identifying the best solution for this particular issue. Unfortunately I still do not have a firm deadline on a fix.

Thank You

Eric Ketchum

Hey Eric,
any news on the issue? Can we hope to get a fix in 4.8? Thanks for keeping us posted…

Hi Veldoras -

Currently it is still being worked on and does not look to be ready for 4.8 release but we do have an active interest in developing the correct fix for this issue.

Thank You

Eric Ketchum

still seems to be an issue in 4.10, cant seem to edit the path to make it an absolute one either. am i missing something obvious? i cant seem to reimport anything

Still being listed as To Do and has not been backlogged, but it is still looking into the issue.

Eric Ketchum

stop gap solution i ve been using is to just import the file back in, asuming no name changes, saying yes to overwrite dialogue seems to work with out breaking bluprints, anim graphs etc

The issue still persists in UE version 4.10.4 but we found a work-around until it is fixed (this information may also help engineers to find the source of the bug).

The work-around is quite simple:

  1. Open the uasset editor.
  2. Scroll down to “Import Settings”.
  3. Expand the “Show Advanced” options.
  4. Disable “Build Adjacency Buffer”.
  5. Save the uasset.
  6. Reimport at will!

This worked out for us but we also found out that everyone working with those assets needed to perform this work-around manipulation otherwise the assets don’t update properly through versioning software (Git, Perforce, etc).

Alexandre Zenga

i’m also getting this issue in 4.11.2. Any news on a proper fix? In the meantime, is there a way to disable the “build adjacency buffer” for all scene assets without having to open the editor for each item one by one?


No fix yet, and Build Settings are not available in the Bulk Edit Properties Matrix. You’ll have to open these individually to disable the setting. A feature request has been entered for this though.

I’ve just tried this workaround. Still doesnt appear to be working, it’s not updating the the uv maps, so I still have to delete and re-import

Hi, disabling the build adjacency on import is not resolving the problem.

Why this marked as answered if it’s not ? Bug still exist in 4.17