Regenerating vs project not working(Unable to open log file for writing)

hey i try to right click the uproject file and regenerate vs project.
but it gives this error message and not working.

Running C:/Program Files/Epic Games/UE_4.20/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/ChangJun Kim/Documents/Unreal Projects/BattleArena/BattleArena.uproject” -game -rocket -progress -log=C:\Users\ChangJun Kim\Documents\Unreal Projects\BattleArena/Saved/Logs/UnrealVersionSelector-2018.11.07-08.43.46.log
ERROR: UnrealBuildTool Exception: Unable to open log file for writing (C:\Users\ChangJun)

some people say it is about whitespace or something.
i really tried to find an answer in google, but most of time just wasting.
hope some one can advice me, any thinkg would be appriciated.

I’m having the same problem. I’ve reinstalled Visual Studio, tried using a script that someone else provided in another thread, upgraded to ue4.21.

None of it worked. I can’t even work on any projects because of this critical error. Let me know if you find a solution man.

Do you have a white space in your path? Try to remove it, I think there is a bug with white spaces.