Reflection problem

on 4.2, everything was fine by defalut. i got nice matte metallic reflections like this: link1

but here on 4.4… i have this: link2

quality settings are all on epic, I set screen space reflections to max quality with this console command r.SSR.Quality 3…

can somebody help me how to fix this?

Hi Jazvecina,

I setup the same scene with the same material (the metal material already assigned) and changed the value of the roughness to 0 (as this is what your second image appeared to be) with no change between the following engine versions:





It looks like the difference in your images above is that the one listed for 4.2 hasn’t had the material changed to make the roughness 0 vs the default .4 setting.

There will be limitations for the reflections though because this would be a big performance hit to reflect the entire scene from any view.

You can see the differences in the Reflections examples in our Content Examples project from the Marketplace.

well this is how the default scene looks like on my 4.4

thats the default Metal_Brushed_Nickel material with default roughness of 0.4

it looks fine on 4.2. all my settings are on epic. for some reason, the matte fuzzy reflections are not working.

its like there’s no difference between medium and epic settings. like it was capped. also what happened right now. i noticed some notification about framerate in bottom right, there was an option to manually tweak, but it crashed before i managed to click on something.

This is still not an issue with reflections directly as these were actually settings that were changed when 4.3 was released.

You can find this in the information for our 4.3 release notes:

Changed default quality of screen
space reflections to start lower for
better performance. It can be changed
in post process settings to be like

As stated this can be changed in the Post Processing Settings under Screen Space Reflections.