Reflection capture - issue with 4.17

Hi folks,

I’m having issues with the reflection captures in v4.17. My question is: can this be a bug in v4.17 or am I missing something…?

  • A Mesh can (it seems) only be influenced by at most 1 reflection capture. i.e. it’s not working on a ‘per pixel’ base as in 4.16 but on a ‘per mesh’ base. This is an issue when using larger meshes (like a floor of an apartment that strenches multiple rooms)
  • The influence radius of reflection captures is not respected (meshes much further than the influence radius of a capture sphere are affected)
  • The reflections seems much more ‘zoomed in’ in 4.17 compared to 4.16
  • The ‘hierarchy’ works fine (i.e. smaller captures take precedence over bigger captures) but as far as I can figure out that’s the only tool available to

I’m working with v4.17 (where I started with a blank project). In v4.16 (where I started with the VR template) everything works as per the documentation.

Since it’s difficult to explain, I’ll try to show with some screenshots. In below,

  • the Reflection Captures setup is exactly the same (or at least that’s my intention). The only differences are some lightmass / light colour settings, post processing, and of course the engine version.
  • two rooms are adjacent to eachother. The ‘frame’ (meaning the walls and ceiling) are the same mesh, extending multiple rooms. Screenshots are of the same wall, taken from one side and from the other side.

In v4.16 it looks like this (which is how I inteded it to look, you can see for example the reflection of the bookcase against the wall):

While in v417 it looks like this (this is not correct. you can see for example the reflection of the bathroom tiles against the living room ceiling and walls):

Does anybody have any idea where to look for a solution to this problem?

Thanks for any help you might be able to offer.


I solved the issue:

Forward Rendering doesn’t handle reflections in the same way. Simply un-checking Forward Rendering (or setting it to False in the config file) in my 4.17 project made the reflections go back to normal.

Not sure if this can be qualified as a bug, but perhaps the impact on reflections could be added to the “know issues” list on <link>

Anyhow, I’m posting this so that others looking at the same issue may be helped :slight_smile:


For each material you want to have per pixel reflections with forward rendering, make sure you go into those materials and opt into “High quality reflections” in the details panel under forward rendering. It ups the instruction count for the shader, but brings back the reflections as they were in the deferred pipeline.