Reduce packaging/cooking time for Mac and Linux?

Engine source build at SHA 5fd5754.

I was able to cook/package for Win64 in about 30 minutes (I develop in a Win64 environment). Packaging from the same machine for Linux took ~15 hours. Packaging for Mac has been going for 10 hours already.

Is it possible to reduce the content cook time for Linux and Mac? I can see that certain textures and levels take 1-2 hours; is it known why this happens? Is there any way to use the cooked content for a Windows build in the Linux or Mac builds?

I’m currently packaging through the editor on Windows and the command line on Mac. Happy to provide an archive of my project if you need a repro case.

UPDATE: I killed the in-editor Mac packaging process and ran it from the command line and it took about 15 minutes.

Did you hear anything back about this? I’m having the same issue!

For whatever reason, packaging from the command line takes a reasonable amount of time, so that’s how I do it now. Happy to share the win/linux/osx commands if you want them.

I didn’t look into what was happening with the editor so my knowledge of the packaging process is still very shallow, so I don’t even have a good guess as to why this happens.

and just like that, Linux distribution compiled and packed in less than an hour!

Thank you sir!! :smiley:

I was thinking it had something to do with my CPU as it runs at 100% when compiling, so being free of having the actual editor open at the same time I guess helps a lot and stops the computer choking!

If it’s possible, please, share the win/linux/osx commands, which you have used.

I can’t remember exactly, but I think I literally just used the very first command found on this page:

(Change the bold!)

RunUAT BuildCookRun -project=“full_project_path_and_project_name.uproject” -noP4 -platform=Win64 -clientconfig=Development -serverconfig=Development -cook -allmaps -build -stage -pak -archive -archivedirectory=“Output Directory

I ran this from cmd. You first must get cmd to the correct directory first where the cook tool is located. I used absolute paths for project and archive path.

I was pleasantly surprised how it ‘just worked’ :slight_smile:

I think being able to compile without my weak CPU having to struggle with having UE4 open at the same time must of helped a lot.

1 Like