Red spline point dots block navigation

Red dots that are there to shape the spline points, are blocking navigation mesh. E.g. drawing walls block AI to pass near the wall end points with big radius.

Hi SaOk,

I attempted to reproduce this but I couldn’t get your results. How exactly are you setting up the Spline? Is it just an actor blueprint with a Spline component?

Hi, yes using the construct in actor blueprint. Tried to have both simplified box collision and complex collision for the fence static mesh (made using BSP), but cant find out how to avoid that. Have had the same issue with different static meshes too.

I’m still not able to get your results. The Red Tangent Line doesn’t cause any issues with the navigation.

Try this: while in the editor, go to the Show button in the Viewport and Enable Collision. See if the spline is perhaps stretching your collision to be longer than your mesh.

The collision looks normal - stays correct. Very strange.

Now the issue went away with one spline type. Not sure what I did, but seems like the issue is in my settings.

Seems like “Is Dynamic Obstacle”-setting in static mesh have the effect. When its off I am getting the issue.

‘Is Dynamic Obstacle’ is off by default but enabling it doesn’t make a difference for me.

Would you be willing to post a link to download a small test project for me to test internally? If it’s smaller than 5 MB you can upload it directly here.

I made spline in test project, but cant yet reproduce the issue in it. I let you know if finding something.

Hi SaOk,

Any luck reproducing the issue?

No so far. I dont have yet ideas why it did that. The wall was made using BSP if that have some effect, but else the collision is correct.

That’s fine. I’m going to resolve this post for now, but I’ll keep an eye out for any other users reporting this and if you happen to get a repro, just post back here to reopen this report.