Download

Recover Mod

Hello,

last week my harddisk broke so i lost all the files about my mod.
I tried but can’t find a way to reimport them in my ADK (tried copy paste the folder but if i try to open a blueprint or anything ADK crash), and if that is possibile, how i can re-upload them over the same ModID?
The only files i still have is what you can download from the Workshop (cooked, it this matter, not sure).

Thanks alot

If you don’t have the source then you’re screwed, to put it bluntly. You’ll have to start over.

You can upload to the same workshop entry by uploading your newly started mod at least once, closing the DevKit and editing the ItemSeamID in the Mods.db file for the mod you just uploaded with the Mod ID from your old workshop entry.

-WM

I highly recommend to use some sort of Source Control (SVN, GIT, Mercurial, …) when working on mods. This way you do not only have a backup, you have a backup of every step you take!

worked perfect thx

I had a similar problem with the upload configuration being corrupted and lost the ability to update my mod recently. I tried this procedure 3 times and it lost the upload config 3 times so it uploaded to a new steam ModID 3 times. This fix doesn’t seem to work anymore. is there anyway to set the GUID along with the ModID and make this work?

It still works fine. You need to close at least the cook window, preferably the entire devkit BEFORE you edit the Mods.DB file or it doesn’t save.
The GUID doesn’t really matter. Basically it sets the “version” if you will. When you update a mod and click “reset mod guid”, all it does is force the client to need the same version as the server. IE: if you reset mod guid, people can’t connect to server until the server also gets updated to the current mod version. Has nothing to do with that actual mod id.