Record Vehicle Animation with Sequence Recorder Issues

Hi all,

I am having an issue while trying to record the animation of a wheeled (drivable) vehicle.

The vehicle needs to permanently exist in the level, so I am recording to ‘possessable’ so that the animation is saved into the original vehicle in the level and not a duplicate etc.

Within the vehicle blueprint itself, there is the skeletal mesh and then there are lights & windows that are attached to the skeletal mesh.

When I record the animation, it seems to work fine. If I scrub through the sequence, the vehicle all moves as one piece as expected. However, If I add the sequence to the level and hit ‘play’ (so that I can use take recorder to film with a virtual camera), I run into an issue where the vehicles skeletal mesh (the main body of the vehicle) stays in one place, but the windows/lights animate (aka, drive off without the rest of the vehicle).

I assume there is some setting I need to check/uncheck but cannot seem to find it. Any ideas? I’ve already tried various settings to do with ‘root animation’ and ‘world space’ etc but nothing seems to work for me.

Vehicle with windows in correct place

When I hit play, the windows drive away on their own without the skeletal mesh (limo body) which is left behind.

Sequence Recorder Settings Below:

Update: Also tried this in Take Recorder and getting the same result. It seems that anything that is a skeletal mesh is being left behind.

Same issue, glad you saw my post, I’ll follow this one as well

Can you try disabling Simulate Physics on the recorded skeletal mesh?

1 Like

Hi Max,

Thanks for the suggestion! I actually found some mention of that prior to posting and gave it a go, but without success. I’m now thinking I did something wrong though so I will give it another shot. It does seem to make sense, because apparently sequencer is competing with the physics engine, hence why the animation gets stopped. I’ll try this again and post my finding!

For future eyes - here is the original article I found from a guy using the vehicle recording to do previz (which is exactly what I am also trying to do)

I am unable to test if this works at the moment, but do have some time to google the problem / potential solution that Max suggested. Happily, finding some new results in forums now. Posting in case anyone else is interested (aka Nino). As I mentioned, I’ll report back once I get a chance to test.

I decided to skip breakfast and test this before work. Got it to work by following Max’s suggestion and Kim Laughton’s steps. Thank you!!!

Will do my best to post a mini tutorial on this :slight_smile:

Ah fantastic! Going to add redirect link from my post to yours

Oh man it worked!
I really really hope this sort of thing can be streamlined later. The fact that it only affects vehicles is odd. There needs to be an option that can be ticked that essentially says “Render exactly what I can see in the editor please” :slight_smile:


Also to note, just for posterity, to remember to turn the BP_Vehicle to “Disabled” if it’s dropped in the world. Got caught up on that again just now lol

Well well well, what did you know.

I tore all the nicely done sequences apart thinking something got corrupted in my vehicle BP haha…

Turns out it was just about turning off “Simulate Physics” in my vehicle’s BP to get it to play the recorder action in take recorder in the final export, otherwise the so called “vehicle mocap” was not being applied in the final render.

Thank you everyone.


I found a different solution: check that “auto posses player” is disabled on the car

1 Like

I got the same issue here,but i sovled it by remove the “process” node in my BP
I think is something about the controller stuff , hope this will help you

1 Like

Hey, having the same problem here, I used all of your fixes and it makes the vehicle appear when I run a lumen export but when I run path tracer in movie render queue the vehicle disappears. Like the previous problem it appears in the editor with path tracer just fine. I am also using take recorder from a chaos rigged vehicle with a BPactor. Any tips on how to get it to appear in path tracer would be greatly appreciated!

Turning off “auto possess player” worked for me. Thanks!