reconstruction stalling the computer at the end : memory filled

It has been a few days that I am fighting with a reconstruction.

The component is a 10,000 pictures mix of 12MP drone pictures and 42 MP hybrid pictures. 1,400 parts to reconstruct. Nothing really fancy, I was able to reconstruct 20,000 pictures components before. But not the same story with RC last version : at the end, when the parts start to become really small (less than 1,000 vertices each), the memory usage explodes and eventually stalls completely the computer. I had to do a hard reboot 3 times already because the computer was totally stalled swapping a lot on the disks.

Is there anything known with last version ? memory leak or something ? I was reading on another post that the reconstruction was “out of the core” and that memory was never an issue, but my 128 GB of RAM are totally filled…

I tried to downscale more the 42 MP pictures (d3 instead of d2), the 12MP pictures staying in d1.

But nothing, always the same… I am a bit stuck here.


Hello Jonathan,

reconstruction should be out of core therefore memory should not be an issue. 

Can you please try to check your scene if there are any misaligned areas or some cameras in the incorrect position? 

Also, please try to change in the Reconstruction settings - Mesh calculation - Minimal distance between two vertices to some value, for example 0.001 (by default it is 0).


Thanks for the hint about the minimal distance, I will check this.

About the misaligned areas and cameras in the incorrect position, it is hard to say on 10,000 cameras. Everything looks ok by looking at the tie points point cloud.


Ok, so same again.

I changed the minimal distance between 2 vertices to 0.001.

I am at part 1041/1238 (397 vertices) and all my 128 GB are filled and the computer starts to swap…

Any idea ? I have been stuck for 2 weeks on this reconstruction. Anything that changed on RC last version ?

Hi Jonathan,

did it work with the minimal distance setting?

no… - even in “normal”/d2 it stalls at the end : part 594/676, estimated 132 vertices, memory full ! (128 GB…)

Do you think it comes from a particular picture ?

I am trying to reconstruct with less and less pictures (rejecting some of them by putting the “Enable meshing” flag to false)…

Is there a log somewhere where I can see what is going on ?





Hi Jonathan,

yes! You triggered a memory of a thread where there were also huge problems - I don’t recall if they were identical though.

From memory, the image(s) causing the problems were ones with extremely few tie points (or features?), which are relatively easily identifiable. I am talking about really low numbers like 1 or 2 digits…


mmmmm interesting… 

I will give it a try, thanks Götz !

My last tests with a reconstruction in downscale 3 gave the same problem. I waited, waited (more than 2 days of heavy computer swapping) and it finished with parts with errors, so there is line-shaped holes in my model…  What is really weird is that I reconstructed this dataset before with a previous version of Reality Capture. So I think something is wrong with last version.

And it did the same on another computer with much less memory (12 GB) but a much smaller dataset (around 500x42MP pictures)… But I will definitely remove the low featured pictures from meshing.



Hmmm, if you are absolutely certain that it did work before it might be worth pointing that out again explicitely. Did you get in touch via contact form yet?

Fingers crossed that it works soon!

no, not yet…

So, I noticed something really weird :

Sometimes when I navigate in a component through the cameras, some of them are marked with a red strikethrough and as “0 tie points”. If I click 2 times on “Enable Meshing”, then it comes back to something normal (a lot of tie points). What is going on here ? I can’t find any logic, the pictures that are strikethrough in red and reported as 0 tie point seem to be random and they are in the component, I can see them properly aligned… Could that be related ?



Whoa, never encountered that before!

But I’ve noticed similar erratic behaviour at times in other details - probably not directly related.

I would start with rebooting - no idea how often you do that but I sometimes run into problems after only going to standby for several days of intense working with RC.

Another idea would be to export everything as a component and import it in a new project.

Thanks for the ideas.

Another idea would be to export everything as a component and import it in a new project.

Yes, that is exactly what I did. The random “strikethrough red 0 tie point” pictures are still there in a projet with only 1 imported component… I started a reconstruction in d3, I will see tomorrow if that worked or not.


Another thing I noticed is that in the image list, all my pictures are reported as “0 features”…

But they are aligned an in an imported component…

Is that after you imported them as component?

That is certainly not normal, I just checked.

You could try and export XMPs in the original project (fingers crossed it still exists) and then click align. In theory it should be done within seconds but might now contain the features. Worth a try?

I am sure you read through new topics, but have you tried re-installing the gpu drivers?

That just solved this issue:

 Thanks Götz, I will try this as soon as my current processing is finished.

Yes, the 0 features and the “red strikethrough” pictures are after component reimport.


saving XMPs may be hard because the 10,000+ pictures I am working with are spread over multiple folders. And component reimporting should work…


True, but on the other hand XMPs will be saved in the same folder and if present RC will use them (maybe there’s an additional setting though).

hello, the “red strikethrough” is a metadata cache problem (filed as a bug 6983), we still do not have stable repro steps to be able to fix the issue, can you help us?

@Götz, you mean that I can export XMPs, reimport previously exported components referencing them and hit align ?

@Lucia, thanks for the info. How can I help you on the “red strikethrough” bug ? I am able to reproduce on a small regular (no component imported) project referencing 3000+ pictures. So maybe I could share this one tomorrow if needed.


I just updated my graphics drivers and Cuda toolkit and started a new reconstruction on my small test project.