Recently we always failed to run "git checkout master"

Repro steps:

  1. git clone D:\UnrealEngine\src
  2. cd D:\UnrealEngine\src
  3. setup.bat
  4. git reset --hard
  5. git clean -xdf
  6. git checkout master

Actual result:
Your branch is up-to-date with ‘origin/master’.
Already on ‘master’
Checking dependencies (excluding Mac, Android, Linux)…
Updating dependencies: 0% (31/30682), 2.9 MiB cached…
Updating dependencies: 0% (63/30682), 7.4 MiB cached…

Updating dependencies: 99% (30629/30682), 5120.6 MiB cached…
Updating dependencies: 99% (30630/30682), 5152.7 MiB cached…
Failed to download ‘’: Non-negative number required.
Parameter name: count (ArgumentOutOfRangeException)

This issue cannot be repro on latset revision.

This issue is unstable. It still can be repro recently. Could you please take a look?

I’m also encountering this issue when trying to update one of my PRs to latest and it is preventing me from doing so.


Sorry for not responding to your post sooner. Are you still running into this issue? I followed the repro steps that were outlined in the original post, but when I ran the git checkout master command, the process completed successfully for me.


Hi Tim, I’ve not had this issue since, but I’ve also not tried checking out my older PRs as other issues usually pop up. I assumed this issue is due to the file that it is trying to download doesn’t exist anymore on the CDN as it got cleaned up. Thank you for looking into this issue anyway.


We have not heard back about this issue for a while. Do you still need help with this? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post if you need any additional assistance.