Receive Draw HUD

It either doesn’t fire or there is something wrong with Draw Text, in 4.11 it worked correctly.

I 't mean to sound rude, but it appears that the engine seems to be falling apart considering the crazy amount of bugs in the recent versions.
The fact that the design team (if there is one.) priorities are more on the add feature instead of bug fixing, it’s kinda worrying.

I 't even know what to say, I 't even know if I should keep working with this engine because maybe something else might not work in the next version that was working on the previous.
Now the lack of consistency in this engine is the least of my worries.

Hello SwordSkill,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue?
  4. Did you try deleting your saved and intermediate folders before upgrading your project to the next engine version?
  5. Could you elaborate on what results you are getting exactly and how they are at an inverse to what it is you are expecting?
  1. This is exactly what I did.
  2. Create a HUD Blueprint, apply it in world settings and use the receive draw Hud to draw a random text. It won’t work, I did the same in 4.11 as was working properly.
  3. No, just try it yourself. I wasted enough time already.
  4. No, I just installed it, and tried it
  5. The HUD doesn’t show.

I could not reproduce this issue on our end with the information provided. I was able to have the text show up on screen as expected. I will need more detailed information in order to reproduce the issue that you are experiencing. Would it be possible for you to provide a simplified version of your project that still exhibits the issue that you are reporting?

Hello SwordSkill,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

did you run this as standalone or from the viewport, because on my end in the viewport doesn’t show and in standalone works fine.

Hello SwordSkill,

I tested this in both standalone and PIE (Play In Editor). Are you running this in SIE (Simulate In Editor (Looks like the play button with a gear)) mode?

I noticed when creating a new HUD blueprint and assigning it to the project, I had to close the editor (project) and load it again. This more than likely just forced me to save everything, but to reproduce the issue and solution:

  • Create a new HUD blueprint
  • Print some stuff to screen
  • See it not work in PIE
  • Close the project (saving everything)
  • Load the project again
  • Play in editor
  • See the issue resolved.


Hello dsmith,

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future reference.

Link: Unreal Engine Issues and Bug Tracker (UE-39062)

Make it a great day