Download

Rebuilding Lost Mod

Due to a terrible event here, I had to reinstall my entire development kit. The new one does not recognize any of my previous mods. I need to be able to re-import them into the mod folder again. Moving them in Explorer and Pasting them there just causes the engine to crash badly and you can not import uassets at all from an external source, still not sure why we can’t after all these years asking for this.

Has anyone had any luck getting an asset from the outside into the ark editor? I really hope someone can shed some light on this, otherwise - both of my mods are now dead.

Assertion failed: BlueprintObj->GeneratedClass [File:H:\SVN_Ark\Engine\Source\Editor\UnrealEd\Private\Kismet2\Kismet2.cpp] [Line: 533]
Invalid generated class for EngramEntry_PearlBedTest

VERSION: 0.0
KERNELBASE.dll!UnknownFunction (0x00007ff81cab7788) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf9366ad) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf81d258) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf7f1902) + 0 bytes [UnknownFile:0]
UE4Editor-UnrealEd.dll!UnknownFunction (0x00007fffde7b5425) + 0 bytes [UnknownFile:0]
UE4Editor-Engine.dll!UnknownFunction (0x00007fffd5efaae2) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe4638d5e) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe46265b2) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe46572df) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe468f0ec) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe46568de) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe468f0ec) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe46568de) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe469622b) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe477f85f) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe478768b) + 0 bytes [UnknownFile:0]
UE4Editor-CoreUObject.dll!UnknownFunction (0x00007fffe478cd24) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbdf79a7) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbd36ea9) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbe1407a) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbd91fa6) + 0 bytes [UnknownFile:0]
UE4Editor-Slate.dll!UnknownFunction (0x00007fffdf40b5fa) + 0 bytes [UnknownFile:0]
UE4Editor-Slate.dll!UnknownFunction (0x00007fffdf41f93e) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbe2d66a) + 0 bytes [UnknownFile:0]
UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007fffcbe1c784) + 0 bytes [UnknownFile:0]
UE4Editor-Slate.dll!UnknownFunction (0x00007fffdf2dd8be) + 0 bytes [UnknownFile:0]
UE4Editor-Slate.dll!UnknownFunction (0x00007fffdf2c9461) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf894b21) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf872ddb) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf895c79) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf86cb82) + 0 bytes [UnknownFile:0]
USER32.dll!UnknownFunction (0x00007ff81fec1c24) + 0 bytes [UnknownFile:0]
USER32.dll!UnknownFunction (0x00007ff81fec156c) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x00007fffdf8969d6) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x00007ff7bb59a713) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x00007ff7bb58f91f) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x00007ff7bb58f98a) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x00007ff7bb59bf50) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x00007ff7bb59ce99) + 0 bytes [UnknownFile:0]
KERNEL32.DLL!UnknownFunction (0x00007ff81fe08364) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ff8205770d1) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ff8205770d1) + 0 bytes [UnknownFile:0]

Yeah - all attempts end in this horse-poo-poo.

Does it work without the PearlBedTest?
Asking them to add functionality to a dead engine version? Don’t hold your breath on that.
You should be able to import, place in your folder, open ADK, import > should work?

Just looked at the mod, and, it looks really neat!

Anyways - was this working before you had to reinstall?
Was there changes that were done before that need done before it loads right? I ask thinking along the lines of there is some functions missing from the BP you made (like some bools or ints or something? maybe a change in core that was done that you missed?)

Close the devkit and copy the files to the proper place into the devkit with windows explorer then use this guide to get your mod id’s back

Well, to answer the questions: Yes. Everything worked great before I had to reinstall the entire epic launcher. There’s no backups to restore, since they are all toast. I’ll cross that bridge once I get the editor to recognize ANYTHING from the mod before hand. The file I chose could have been ANY file from the mod. I just happen to have chosen that engram at the time to show the constant errors being thrown. It’s looking like I will have to reconstruct the entire mod from scratch. Such a waste since the ENTIRE thing is sitting right there.