Download

Rebuild in Visual Studio broken

Hello everyone,

in 4.18 the C++ programming in VS was a total mess. In 4.19 some bugs have been fixed.
But I am again no longer able to Rebuild the project in VS.

uevsmess.PNG

I get this message:


Unable to clean target while hot-reloading. Close the editor and try again.

Prior to 4.18 the VS integration was perfectly fine. I had no problems at all.
Using normal ‘Build’ is not an option, sometimes you got to Rebuild everything. Also closing the Editor each time is not an option.

Does anyone know how to fix it?

Thanks

Close the editor. Hot reload has never worked properly.

Rebuilding worked from 4.15 to 4.17.
By the way a normal Build is also a hot-reload.

The solution just a delete Binaries only.

I always build outside the Editor as well because hot-reload has always been kinda flaky…

Wait, you close the editor each time you make a change in C++?

Hot reload works fine in most cases for me. Rebuild should only be used when something unexpected went wrong otherwise you are just wasting time deleting and compiling things that haven’t changed. Especially on minor changes it would be overkill to do a rebuild.