Download

Rebuild all engine each time I build any project. Very long times to make any minor change.

When I build any proyect, even when I build a new project, the whole enigne rebuild each time.
Even I has tried to install a new Windows installation in a new computer that only holds the Unreal Engine, Visual Studio and Git and CMake tools, and GPU drivers installed. No games, no other apps.

If someone can tell me what I’m doing bad I would be very gratefull:

To install the engine I do:
[ul]
[li]Download the engine from github with “git clone” in the SSD drive.[/li][li]Run the Setup.bat and GenerateProject.bat[/li][li]Open the UE4.sln file[/li][li]Select Buid > Build Solution (take almost 4-5 hours to complete.[/li][/ul]To run the engine I try two ways: [ol]
[li]Running from Visual Studio with Debug > Start Debugging[/li][li]Open with double click the file at Engine/Binaries/Win64/UnrealEditor.exe[/li][li]Then I wait to complete all shader compiles.[/li][/ol]
To run a existing project: [ol]
[li]For example, to running the ShooterGame example, I first download it from Epic Games Launcher to SSD.[/li][li]Generate Visual Studio Project Files clicking in the .uproject file[/li][li]Open the solution and compile.[/li][li]This recompile a big part of the engine.[/li][li]When finish and the project it’s opened, I close it and delete the next folders in the project:[LIST=1][/li][li]Binaries[/li][li]Intermediate[/li][li]Saved[/li][li].vs[/li][li]*.sln[/li][/ol]
[li]And then generate a visual studio solution again, open the sln again and build again:[/li][li]This repeat the engine building that takes a lot of time (1 hour)[/li][/LIST]To run a new project: [ol]
[li]Open Unreal Engine from .exe and from Visual Studio (both with the same result)[/li][li]Create a new C++ project.[/li][li]The new project takes 352 seconds in generate the new project (with a installed engine this takes no more than 1-2 minutes)[/li][li]When finish, I run with Debug > Start Debugging[/li][li]This takes around others 10 minutes to load DLLs[/li][li]When open the project, I close it, and delete the sames folders that I did in “To run existing project”:[/li][li]Generate again the solution and buld again: this takes others 30-60 minutes and the same process of DLLs.[/li][/ol] How the people works with the engine when download from Github?

I followed the complete guide to install Visual Studio, including the install of Visual Assist, VS Unreal and the options in visual studio to not show some errors.

Thank so much

After create a project and open it, I create a Character C++ class that takes more time than takes in installed engine version.
But… after change a boolean from true to false in the recent created class, VS throws this log and takes a looooong time to finish.

Any ideas why it builds over and over the engine?

I noticed a big improvement when build the project from UnrealVS instead build solution from Visual Studio, but still takes a very long times :frowning:

How long does it take to compile one of the starter projects that comes with the unreal engine editor? Like the twin stick one or first person one when doing it 100% through the editor

In general, the first time I compile a project after switching engines is the slowest. After that it is fast and incremental. (About 20-60 seconds)

From your log it looks like its building all the engine binaries ( not sure why, but sometimes that happens for me , but only on the first build of the game project. After that, it should just have to compile your game dlls only).

Some tips…

  1. After you create a project, right-click and select “Switch Engine” to your downloaded github engine.
  2. After it generates solution, open file in VS.
  3. Select the game project in VS in the left hand project navigator, then right-click and select “set startup project” (Sometimes this gets set back to UE4).
  4. Make sure to set solution configuration to Development Editor, platform to Win64 ( if the toolbar dropdowns arent wide enough, you can make bigger - see https://docs.unrealengine.com/en-US/…tup/index.html to configure vs for ue4).

Also - I highly recommend enabling Live Coding. If your code change doesnt modify any headers, then just hit ctl-alt-f11. Takes me about 10-15 seconds to fully hot patch. This is a game changer for iterative stuff. To enable, in pie editor, drop down arrow next to Compile button and “Enable Live Coding”.

Hope that helps

Creating the FPS Template to 4.25.1 from github with Visual Studio 2019 and Visual Assist X and UnrealVS extensions installed:

  1. Opening .exe (instead opening from debugging in Visual Studio)
  2. Create a new C++ project
  3. Open VS solution:. [TABLE=“border: 1, cellpadding: 1, width: 500”]

Generate project:
19 seconds

Open Visual Studio
34 seconds

Updating IntelliSense (while VA Parsing)
13 minutes

Left time to finish VA Parsing
28 minutes

Build Startup Project (with UnrelVS)

  1. UHT:
    44 seconds

  2. Idle time: The cpu are 100% but log dont say nothing
    24 seconds

  3. Build
    18 seconds

Total time to 1º compile:
~45 minutes

During all process my computer are really bussy: [TABLE=“border: 1, cellpadding: 1, width: 500”]

CPU
100%

RAM
4.6/8.0GB

SSD Disk (where engine and project are located)
1~3%

Other disks
0%

GPU
2%

Other ways I compile the project:

  • If a build again, just after 1º compile are finished, the process takes: 6 seconds
  • If in [PROJECT_NAME]Character.cpp I change the line 26 from this:

BaseTurnRate = 45.f

to this:

BaseTurnRate = 0.f

Then the buld takes: **13 seconds**
  • Close and re-open solution, without alter any file: 5 seconds (+ Visual Studio loading, around 10 seconds)
  • Delete Binaries folder and re-open solution, forces to Visual Studio to VA Parsing again. Notice that while VA it’s parsing, the CPU are 100% bussy: ~30 minutes.
  • If delete the same Binaries folder again and open de .uproject file instead build from Visual Studio, then the process thakes around 6 second

Also I noticed that a difference from engine installed versión, when you generate a visual studio project for a project, inside .vs folder, unreal create a copy of a big part of the engine (around 1.6 GB of source files) I think this is the cause, along with Visual Assist and IntelliSense to take so long to compile.

But Visual Assist are recommended by Epic, so I suposse that the tool itself are not guilty.

Any idea how fix this?

Thank you for the tips :slight_smile: I noticed that building a solution force to finding across al projects of UE4, plus mine. But buidling the project (I used the UnrealVS) increment the compile, but as su can see in my previous post, seems that Visual Assist increments the time, I’m not very sure