Realtime collision not generated for splinemeshes in packaged game

This bug occurs on the following scenario: take a splinemesh with no default static mesh and collision turned off. Then add a static mesh. After that turn collision back on. And there is the bug: the splinemesh has working collision in editor, but not in a packaged game.

After searching a bit I found this, it is apparently a year-old bug that still hasn’t been fixed: Spline mesh collision missing from packaged build - World Creation - Unreal Engine Forums

Recreate: make a blueprint with a splinemesh component and add this (the New Mesh being a mesh that has collision):

Also enable mouse events by making a custom gamemode and playercontroller. Then when you click on it in editor it should print Hello. And when packaged it doesn’t print that.

Packaged for windows 64 bit

Version: 4.11 Preview 5 (also tested in 4.10.3)


I have been able to reproduce your issue, and have entered a bug report (UE-27296). Thank you for your report. I will provide updates on this issue as they become available.

Have a great day

I have this same bug in a 4.13 project as of 14 Oct 16. I’ve tried packaging for Windows and HTML5, same result with both packages.

Hey H.B. Fowler,

Are you able to reproduce this issue in a clean project? If so, can you please provide a detailed list of repro steps?

I’ve heard other reports of this issue lately but haven’t seen it occurring on my end so I’d love to have a consistent repro case for it.

Haven’t had time to reproduce in a clean project. What I have been able to determine is that the problem occurs with spline meshes that are dynamically generated at run time. If I place the spline meshes in the map directly, collision works when it’s packaged.

Sorry for the delay. I’ve spent some time attempting to reproduce the issue, but I haven’t been able to do so as of yet.

Would you mind providing a screenshot of your setup that you are using when you’re seeing the issue occur?

Here you go, you can PM me a link to download it on the forums:


I can provide you with a link to download the project if you like. It’s a class project so I have it uploaded to the cloud for grading purposes. If you can provide me with an email address I can send you a link. I’d prefer not to provide the link publicly.

I’m not seeing an option to send you a PM, sent a friend request. Do I need to be a friend first, or do some other thing to send you a PM?

H. B. Fowler,

For our project, we found a work around to this issue by adding a box collision and calculating the extreme points of the spline’s control points. We wrapped it in this collision box and set it to generate overlaps only. We were then able to create this box on begin play, and perform the collision queries we needed with the box.

The Send Private Message button should be right under the Epic Staff badge under my name:


Are you able to see that & are you sure that you’re logged in when you’re looking at the page?

I’ve verified that I’m logged in, only options I have are to add as friend, ignore, then the find post and threads bit.


I’ve got it, thanks. Feel free to delete it.


Of note: It’s a 4.13.0 project, the spline meshes in question are loaded in the runnerTrack Map. The straight spline mesh attached to the starting platform and manually placed in the level appears to work, the other spline meshes are brought in dynamically at runtime and those are the ones that the collision is not working on. Works fine in preview mode, but not when packaged.

If you have any question feel free to email me: [edited]

Unfortunately, it looks like the project is failing to package on my end. Are you experiencing the same issue if you attempt to package the build you sent?

Delete the VehicleAdvHud object in the “/VehicleAdvPB/Blueprints/Herb” directory.

Forgot to delete that before I zipped it, sorry.

Sorry for the delay. I spent some time in the project, but was unable to determine what would be causing the issue. Unfortunately, at this time, we are unable to dedicate further resources to debugging that project, as it is fairly complicated in terms of the setup. If you are able to reproduce the error in a simplified test project, please let me know and I’ll be glad to continue investigating.

Unfortunate, but I understand. Thanks for looking into it.

Still an issue in 4.26.0

Any updates on this? Would love a dynamically generated spline mesh in my game that has collision