Download

REALLY slow compile times (clang++.exe)

I’ve made a copy of my game from 4.10 to 4.11 and whenever I try to compile it the compiler seems to take an extremely long time compiling various cpp files. My project is actually blueprint powered but I suspect that’s not related to this issue.

Here’s a clip from the output log: MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [148/215] clang++.exe UELinkerExceptions.cpp [armv7-es2]

Each of these cpp files takes several minutes to compile. In 4.10 my game would compile in under 3 minutes, today I went out and came back three hours later to only find the engine still compiling. Is there a new setting in 4.11 to disable this method of compiling?

Did you delete the Intermediary directory after you upgraded? :slight_smile:

I’ve tried both with it there, and with it not. Results are the same. Second compiles take just as long.

This is a somewhat odd guess at trying to help you, but…

You can try doing a full cleanup and then adding the flag –enable-optimized

I found this here: http://goblincoding.com/2013/11/02/very-slow-clang-build-times/

Also, in another website, someone pointed out that the debug version of clang is way slower. If you built yours from source, might be a good idea to check if it was built in debug accidentally.

I hope this helps you in some way. (Otherwise, I’m out of ideas :frowning: )

I downloaded both the epic released version and compiled another with some special addons. I thought my game was launching using the epic release but it was actually using the one I compiled.

It looks like the compile was marked as ‘development’. There is no release build option. There is a shipping but only a few of the tools are marked to be compiled. I suppose I can mimic the development build option but mark everything for release. I’ll let you know…

Update:

When I compile my game using the Epic release compile times are normal.

When compiling while using a modified source set to a release build the compile times take hours.

I’ve been told since my project is blueprint based I must compile the plugin into the source in order to take advantage of it. That being said, I’m at a loss here.

Update 2:

I believe I discovered the issue, kind of. I followed this guide into getting UE4 to think my project was cpp based so that I could add the plugin: I Don't Know UDK: Unreal Engine 4, Blender and Substance Designer Tutorials: How to Get Plugins to Package Correctly in Your UE4 Projects

After doing so I was able to access the plugin features inside my game. Then I begun to compile, and that’s when I noticed the clang++.exe has once more shown itself – compiling away. But wait, this time it only compiled the new plugin files, and the fake cpp file I added. I now realize the reason it was taking so long is because previously because it wasn’t just compiling my game, but the entire engine!

Even though the plugin features are now accessible via blueprints the game also now crashes on load; this was not the case when I compiled the entire engine through the UE4Editor as mentioned above. So, who knows. Back to square one.

Glad you managed to make it work! :smiley:

I have this problem with 4.13 and i tried the cpp file thing but i cant select to Build it in VS 2015. Is there any other easyer way to fix this issue ??

Octobuild could help even on a single machine.