Realistic mobile view - problem

Hello everyone,

the problem is that the mobile preview looks bad and not realistic, kind of there is a problem with shaders/lightning or something. I know that It can looks better, beacause i have seen videos on youtube. There is no problem with preview on Shader model 4/5 prieview. I’m adding screenshots. I’ve been looking for some parameters related with mobile preview in project settings, but no result. Please help me. No idea what to do.



What kind of software do you use for viewing the renders afterwards?

If you give me a couple 360 images, with your permission, I can try and set it up so it looks nice on theViewer app

Unfortunately, its hard to say what you are doing wrong at this point

after changing the rendering engine version, are you re-building your scene?

Hey KrisKarn,
I’m not sure what do you mean, when you are asking about renders and 360 images .

I’ve got problem with proper display for my scene when changing prieview rendering level to mobile. My scene just looks bad and i want to get quality like this : . My “bad” scene looks like there is no lightmaps included.

It just looks like its not built. Try what ‘emrahgunduz’ mentioned, and just rebuilt the lighting after changing rendering type

I got the same problem and made me angry because i was building the project in vr mode and packing to the mobile directly , to solve it i removed the sky light and all the volumes and build the scene once they are ok i start adding back them again , try the same and am sure it will help

I have done it - no result. The lighting is rebuilt in the preview level - shader 5 it looks fine, but when i change to android preview it looks bad.

I found solution. Problem was in Skylight settings. The mobility must be set on static. Not stationary