Realistic candle fire (wip) nvidia gameworks

hey all,

ive got my new nv card and was able to finally play with nv gameworks, especially with turbulence. its fun but its lagging of alot of features and crashes from time to time. i came up to make a realistic candle fire for a start ( yeah cristmas time :wink: ) next im going to make a flamethrower and some explosion. btw you cant really use that in game because of the performance but for a key element or cinematics it would fit. i hope you like it.

@olek, more detail on how to set this up and such would be awesome :slight_smile:

Really nice work, looks great.

hi and thanks,

  1. you need a nvidia card!:slight_smile:
  2. go to and download the turbulence sample projects
  3. go to and download the source and compile the editor (thx GalaxyMan2015)
  4. create a new Project and import the content from the turbulence sample project to get u started. play around a bit with the samples to get a overview.
  5. create a new particle system in cascade. make sure ur emitter is using gpu particles. right click your new emitter and create a field sampler module. for example use the grid FS. in the grid FS module select one of the field samplers from the turbulence sample project.
  6. configurate the emitter and modules to your needs (spawnrate, color, opacity…)
  7. to control the actual sim you need to get into the field sampler which u are using (in the content browser). there you can control things like velocity influence, grid detail, noise … after changing something you need to save the sampler and restart the sim in cascade (or decativate and reactivate the field sampler module) to see some changes.
  8. create a candle model in your 3d app. import into ue4.
  9. create a socket on the candle static mesh where the flame should be.
  10. create a new blueprint. put your particles emitter and mesh into the bp and connect the emitter to the candle mesh socket.
  11. done. make sure that geometry that should collide with particles have the option “block turbulence” ticked on. have fun

if you want to emit light to your level you have to make another emitter with some fake cpu particles. gpu particles dont work with the light modul :mad:

btw maybe someone could point me in the right direction. as you can see in the above video when the candle moves (the particle emitter) your getting this strange looking smeary line effect. for me it looks like the emitter is updating infrequently. ive increased the time delation of the particle system which gets rid of the smearing effect but the whole particle simulation goes crazy. thx