Re-parenting a deleted Blueprint

Hi, I have deleted a blueprint that was used as a parent, and now several other blueprints fail to load because of this error, the UE4 keeps crashing when ever I try to load any of these blueprints that had that as a parent, how can I fix this?

I know certain codes are frequently used as a reponse to the issue yet It did not solve it for me, I used this;

An placed it inside the Defaultenginge.ini under [/Script/Engine.Engine], where as;
+ActiveClassRedirects=(OldClassName=“BCDamageLogic”,NewClassName=“BCNew”) & even tried;

Neither worked.

Help please, I am frustrated and yet again behind on my project due to errors :frowning:

Never force the deleting of a blueprint. Since now I suggest you to take a look at the reference viewer before delete. Now the only thing you can do is to get the nearest backup of the project and recover.

If you don’t have any backup you can TRY to type the name of the deleted blueprint in the search bar (the same of view references) buy I don’t assure it could work.

The last but most stressful solution is to try package (obviously you’ll fail), get the output log, paste it in notepad, find “error” and analyze all the errors lines.