Re-installed launcher not recognising downloaded engine


After a major hardware upgrade, I had to re-installed my operating system (Windows 8.1).
I was already using Unreal Engine 4.1 on my previous OS instance and my installation directory was not same as the C drive, therefore the windows re-installation did not remove my downloaded engine files.

Although, on re-installing the launcher in the exact same directory as before, when it opened it started to download the engine again (I had selected version 4.1 which was already present in my computer following the same folder structure as before.

I also read a similar question’s answer to installing engine on multiple machines without downloading again but the problem with me is that I have the engine files but I did not save the Epic folder in ProgramData from my previous windows installation.

How do I make the launcher recognize the existing engine files?

Thanks and regards,

Hi zun3 -

You can use the UnrealVersionSelector.exe which should be found in the “Unreal Engine\Launcher\Engine\Binaries\Win64” and register your folder as the unreal installation.

Let me know if you still need help -

Eric Ketchum

Hi Eric,

I tried using the same but when I open the UnrealVersionSelector.exe it just prompts me with a “Configure this directory as an Unreal Engine installation?” question instead of asking me the location of where the engine installation is present. On agreeing to the question I get a “Registration Successful” message but the launcher still prompts me to install the 4.1.1 every time I open it.

Hi zun3 -

You said that you had the engine installed in two places or had moved the engine from one place to another, you should be executing the UnrealVersionSelector in the directory that you want to register only.

Also, 4.1.1 is a hotfix and not a full release version that should be downloaded automatically to a 4.1.0 release as it fixes a bug relating to compiling shaders in the engine.

Thank You

Eric Ketchum

Hi Eric,

When I downloaded the engine the first time, it was 4.1.1 .
Also, I did try executing UnrealVersionSelector in the directory that I wanted to register but it didn’t work.

Just to clarify, following is the directory structure:
Drive:..\Unreal Engine
{“4.1”, “4.2”, “DirectXRedist”, “Launcher”}

  • Inside the curly braces are the folders present in the location mentioned above.

I copied the UnrealVersionSelector to the folder "Drive:..\Unreal Engine\4.1
and then I executed. The launcher still isn’t detecting it.

P.S. I understand that I might be seeming a little under-learned with my constant querying about the same scenario. Somehow I’m unable to resolve this on my own

Thanks again for your efforts,

Hi zun3 -

No probelm, we are happy to help. You may have just confused me though. You should not have to move the UnrealVersionSelector from its original location, and in fact you shouldn’t.

To clarify, You have 2 full directories with Unreal 4 installed, one at, for example, “C:\Program Files\Unreal Engine…,” and the other at, for example, “D:\Unreal Engine…” In this instance you would want to register (use the UnrealVersionSelector) in the original location in whatever directory you want to use. In addition you would want to make sure that the Shortcut on your desktop is linked to the correct executable file, so in my examples I would make sure that the shortcut links to “D:\Unreal Engine\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe”

If I am not understanding you exactly let me know.

Eric Ketchum

Hi Eric,

I checked with the new launcher after updating it.
The new interface is more clear where it also shows the projects.
It was detecting my projects correctly but not showing any Engine installations.
I believe it was because of some missing Engine update.

Nevertheless, since I had to update, I’m now downloading 4.2.1 instead :smiley:

Thanks a lot for your support.
And apologies for my misunderstanding.


Hi i have the same problem. I installed “UnrealEngineInstaller-1.5.1-2214492.msi” and “UDKInstall-2014-05.exe”. When I open the Launcher it says “No Engine Installed”.

I tried everything you said before, but launcher still in “No Engine”. Why? Have I installed a wrong version?

Please Help.



If you have copied the engine to the same folder as it should be expected, then there is a trick you can try which will allow the Launcher to simple verify the installation and not have to download anything unless some files are corrupt or out of date.

Here’s a couple links to other posts that have the trick explained, follow the one of your choosing :slight_smile:

Thanks Swifty it works perfect for me! (I’ll let the links here):