Re-Importing FBX (Not merged) not working

Hi All,

I am importing an FBX model of a room leaving “Combine meshes” un-ticked. This works fine and separates the meshes as I would like.
However if I make a change and over write the FBX, Unreal begins to re-import each mesh using “Combine meshes” and I end up with the entire room imported dozens of times.

Is there any way to update one of the individual meshes after it is separated like this? I hate to draw comparisons to Unity but I wish it worked a bit more like that.


Hi, this post is just over a week old but I have the same problem. My entire scene is in one file in Max and whenever I re import a model (even after something small like tweaking UV’s) that particular mesh will re import as a combined mesh (i.e. will be replaced by the whole scene).

Only work around is to delete that particular mesh, rebuild lighting do you don’t get memory reference warnings, and then delete only that particular mesh from the CB. After that, just import the whole scene again (it will import that particular mesh and leave the others as they are already imported).

It’s definitely a bug, and was reported as such a good few months ago, but there’s not a lot of info on the internet about it so I assume it’s fairly rare.

I think it’s a new UE4 feature…it will automatically update the asset in the content browser if the original file gets modified on your hard drive. It’s very useful when tweaking textures in photoshop by not having to reimport it all the time. There is probably a way to turn it off in the Ue4 settings.

I think it’s in Editor settings> preferences, look for “Auto Reimport” option.

I also reported it here bug number UE-1434.
Very annoying.