Razer Blade PRO 17 Display & Engine Crash Solution

For anyone out there developing using the PRO 17, you might have noticed an issue with the OS display crashing whenever unreal crashes. If you change your refresh rate to 60hz from 360hz, unreal crashes will no longer crash your display as well. You can do this through the NVIDIA panel or through Windows.

If the problem still persists make sure you have the latest Razer and Nvidia drivers. It also helps to set NVIDIA as your default processor. The path is NVIDIA Control Panel → Manage 3D Settings → Global Settings