Rapid mouse button clicks return "uneven" number of Pressed/Released events - (bug?)


Under normal conditions; when we

  • click the mouse button, UE4 fires a PRESSED event
  • release the mouse button, UE4 fires a RELEASED event.

It is supposed to be 1 release for 1 press, right? - Well, not in my case!

Problem: When I rapidly keep on clicking right mouse button, I sometimes get 2 release events for 1 press. (Either a missing pressed event, or double released events). - I wonder if it is a bug or something else…

In order to isolate the problem, here is the list of things I’ve done…

  • Create a Third Person Blueprint Template
  • Go to Project Settings > Engine > Input, and create a right mouse button event in Bindings > Action Mappings
  • Open Level Blueprint, and inject the following simple code:


  • Compile, and Play!.. While changing the camera angle by moving the mouse, start clicking and releasing the right mouse button VERY rapidly (like crazy). Sooner or later, you’ll get DOUBLE released events! - It is very strange that, when you move the camera a bit, the weird pressed/released condition gets fixed. It seems to happen only in some viewing angles! For example, the camera angle that I’ve screencaptured (above) causes uneven pressed/released relationship…

Question: Is this normal?

Hi Dynamo,

Per your instructions, I created a Third Person Blueprint Template and added the corresponding code but was unable to reproduce the issue in the 4.4.3 build. (“Pressed” and “Released” fired without duplicates even after numerous attempts.)

If you haven’t already, try updating to the latest build (and/or) try recreating this issue in a clean (empty) project.


Dear ,

Thanks for your kind reply.

I am using the latest version (v4.4.3).

Before posting here, I have tested this issue twice in a clean (empty) project. I am afraid, the problem remains the same.

As it happens (almost) randomly, it is a very annoying issue. Very hard to recreate the case. It happens only in certain camera view angles, and I really don’t understand the cause of this problem, which is somehow related to relationship between camera angle and mouse events :frowning:

Kind Regards,

Dear envenger,

After receiving your kind reply, I have disconnected my mouse. And, I can still recreate the issue using my notebook’s touch pad.

It can be due to your mouse. I don’t know exactly how UE4 click detection works but I had similar problems using another software called autohotkeys where it wont detect when I release the button.

The problem decreased when I got a gaming mouse but it still happens once in a while.

Try with another mouse and see if you get the issue.

Update: I have just tested the relationship between the mouse click issue and the camera angle… As soon as I get the issue, I saved the control rotation of camera to a variable. Moved the camera to different location, and went back to precisely previous rotation by using the stored variable. The issue is gone for a second. As soon as I move the camera again to a different angle, it’s back!

Result: I can not recreate the issue by saving and restoring the camera angle/rotation where problem occurs. Issue seems to be very random, hard to replicate :frowning:

Hi Dynamo,

In order to help us trouble shoot this more accurately, please create the following in your level blueprint (where “InputActionDebug” = “Right Mouse Button” on your end.) This will add an integer to the Pressed/Released message so we can more accurately gauge how much is being detected. -As we tested this ourselves, we saw consistent numbers regardless of camera angles. We also tried to recreate the issue in the Selected Viewpoint, Standalone Game, and a new Editor Window.


Hi ,

Thanks for your kind reply!

Here is the screenshot:

I can confirm that it occurs in Selected Viewport, Standalone Game, and new Editor Window.

Hi Dynamo,

In order to determine if this is hardware related, please provide your system specs. (Click start button, type dxdiag in the Search box and press enter. Press “Save All Information” button and send the text doc as an attachment.)

You’ll also want to try showing FPS in the Viewport. –If the FPS is slower than the rate you’re clicking it will not be able to register the every click.


Hi ,

Thank you for your kind support.

For debugging purposes, I always print the frame rate on screen. My notebook is powerful enough for a “stable 60 frames/sec” performance, and the amount of calculation performed per frame always takes less than 18 ms. So, the issue is most probably not related with hardware performance.

I wish I could say the same thing for low-level drivers! Although my drivers are always up-to-date, I have no idea about what’s going on under the hood. In order to check my input devices against DirectX, I have searched the web for a DirectInput based mouse diagnostic tool/utility. No luck! I wish I had a chance of testing low-level mouse events in a similar way that you use in UE4.

To prevent uneven mouse events, I am using a bool variable in blueprints which is toggled by mouse pressed and released events, as a quick-and-dirty fix :wink: - Best scenario would be identifying the cause of this issue, of course.

Anyway, I have attached the system specs file you requested.

Thanks again!

link text

Howdy Dynamo,

Thanks for reporting this issue. Since you are running Windows 8.1, i may have found a way to fix your issue.

Go into your PC settings > Mouse and TouchPad > and then under Touchpad, put No Delay.

Please let me know if this helps you with your issue.

Thanks and have a great day!

Hello Sean,

Thanks for the tip!

I’m afraid problem remains the same.

How you attempted this issue in earlier builds of UE4 or in the 4.5 preview of UE4?

Hi Sean,

To be honest, I was unaware of this issue until this week.

After receiving your question above, I have downloaded previous versions of UE4 and noticed that this issue even exists in v4.1.2, at least for me. Haven’t tried v4.5 preview yet, waiting for the final release.

Howdy Dynamo,

Just wanted to check in with you and see if this issue is still happening for you since the 4.5 release yesterday. Please be sure to let us know when you get the chance.


Hi Sean,

Today, I have upgraded to v4.5, and the issue is still happening for me.

Kind Regards,

Hey Dynamo,

I have been looking into this issue over the past couple or days and have been unsuccessful with any repro so far. I was thinking that this issue may be one with your PC set up for you mouse/touchpad. You may want to contact Alienware support and see if the issue can be fixed through them. Here is a link to there site: http://www.alienware.com/Landings/laptops.aspx.

Please be sure to let me know if they are able to fix the issue for you.

Thanks and have a great day!

Hey Sean, I just attempted to reproduce this as well. I have a Razer DeathAdder 2013, and I have been unsuccessful in reproducing this issue.

Dynamo, is your mouse a PS/2 mouse? Do you have a PS/2 slot that you could try plugging one into and see if the issue is still there? To me this almost sounds like an issue with OS/drivers moreso than a hardware issue. Do you have another PC to test this project of yours on?

Hey Sean,
Hey walk12288,

Sorry for the delayed feedback, I was busy with testing this issue on some other computers.

Good news for you, bad news for me!

In order to test this issue, I have installed UE4 v4.5 on 3 different PCs. No hiccups at all. In all cases UE4 performed well. Since we all can not reproduce this issue, I think we can confirm that it is an Alienware related issue.

I presume, the case is closed :wink:

Thank you very much again for your kind support!

(Just for the record; Even after a clean Win 8.1 installation and a reliable USB mouse connection, problem remains the same on my Alienware notebook. If anyone has a similar problem, I recommend toggling a simple bool variable on each mouse click event in blueprints against uneven clicking as a quick fix.)