Random unplayable lag, after no change? How to profile a specific blueprint?

I suggest to plug off parts of the actor to see with function does it, from there you should look for other actors that a function spawns or talks too(if there is). Check how many instances you are spawning there is a chance that spawns function called thousands of times.

It’s possible but at the same time it can be some other stuff, sometimes the engine doesn’t compile some blueprint fully with can create weird bugs but usually it will show you errors. You can try to recompile the blueprint and if you want you can drop it here for us to look at.

I deleted a whole bunch of unused assets and for some reason I went from getting a perfect constant 120 fps, to around 20. My project is 100% unplayable.

Even in an empty scene I get this lag.

Stat gpu and scene rendering are showing nothing out of the ordinary. Everything is bright green in the show shader complexity. I found out it’s my blueprint that controls terrain spawning but it only uses hisms so I have no idea why it’s causing lag. And I didn’t change anything about it. But if I disable it, I get 120 frames. Enabled, back to 20. And it doesn’t make sense as it runs one time to generate the landscape, and then it is done. With all of it’s settings turned all the way down there is only 100 hism tile actors. With a very simple grass material, which is just a flat green texture.

How do you profile a blueprint?

Well, I assume it’s some sort of odd engine bug since it started pretty much unprompted, I’m updating to 4.25 to see if it’s any difference and if not I guess I’ll have to get into the nitty gritty with it or something.

Well, I appreciate your help, it ended up fixing myself after I updated to 4.25, I’d imagine it’s just some sort of extremely specific engine bug?

Thanks anyways, my next step would of been to pull it apart to the bare essentials and from there post to community.

I updated to 4.25 and it randomly fixed itself, some sort of odd engine bug? Who knows.