Random things stops working all the time

I am absolutly sure 99.99% of these “bugs” is just your inexperience. If you want help give us more information.

Hi! Whatever I do I get these random errors where things just stops working. If I code on object A, then object B or C suddenyl not work as expected (as coded), even though it worked the last 500 times I tried it. This has happened to me so many times Im starting to lose hope in this ridicolous engine. One example is the delay nodes. Sometimes, even if it has worked for many months, they suddenly dont fire and they skip nodes past it. This makes delaying code totally impossible. I cant code games if the code only functions properly every third time. I am so sick of this. Another example is sound atenuation, sometimes when having override the sound doesnt play at all. All all the collision bugs where collison fires sometimes and sometimes more than once…I dont even know where to start. This engine is the biggest joke in history. Please dont make updates so often, epic games, PLEASE work seriosuly on all ridicolous bugs and come back in three years or more when you have a more stable enginge. Im chanign to Unity now.

So to the question ofcourse, any one else experiencing these random bugs appearing from nowhere?

Thanks

Some of them maybe, for sure. But a sound cant stop playing in actor B if I change only independent things in actor A. Just cant. Never.

  1. Delay nodes stops working sundnely after having worked along time

  2. Sound autentiation stops working (sound isnt playing) without even being changed by me…

Heres a pic of my 1st problem:

OK but I should be able to deactivate it right?

What about the sound that just suddenly wont play?

And why did all of this work perfecly fine a week ago? See where Im getting at?

Thanks alot

Again if you want help give us more information (some pictures for example).

You can only destroy a component inside that blueprint where it’s added.

I just tested it because I have never used deactivate before but it looks like you can deactivate particle effects of B-BP in A-BP

Are you sure in all that delay time nothing else is overlapping before that deactivate-function does fire?

Try this.

So now ALL my delay nodes doesnt fire. Not a single one. No matter which actor…This is a bug. Its ridicolous

I’m having a very similar issue.
I have this code:

AFPSChar::AFPSChar()
{
// Set this character to call Tick() every frame. You can turn this off to improve performance if you don’t need it.
PrimaryActorTick.bCanEverTick = true;

bUseControllerRotationPitch = false;
bUseControllerRotationYaw = false;
bUseControllerRotationRoll = false;

GetCharacterMovement()->bOrientRotationToMovement = true;
GetCharacterMovement()->RotationRate = FRotator(0.0f, 540.0f,0.0f);
GetCharacterMovement()->JumpZVelocity = 600.0f;
GetCharacterMovement()->AirControl = 0.2f;

cameraBoom = CreateDefaultSubobject<USpringArmComponent>(TEXT("cameraBoom"));
cameraBoom->SetupAttachment(RootComponent);

cameraBoom->TargetArmLength = 300.0f;
cameraBoom->bUsePawnControlRotation = true;

followCamera = CreateDefaultSubobject<UCameraComponent>(TEXT("followCamera"));
followCamera->SetupAttachment(cameraBoom, USpringArmComponent::SocketName);
followCamera->bUsePawnControlRotation = false;

}

Worked beautifully last night, so I saved everything, closed it, went to bed, woke up in the morning, opened everything up, tested it again, literally nothing worked. So I commented out all the lines of code that aren’t default in the class, added them back in one by one compiling and testing each time, lo and behold without changing anything my code works again.

I’m sure tomorrow it will break itself again. WTF??!?!?!?!?! I have never seen a coding program that will work and then break without me changing anything. I want to say it’s user error, but I just cannot see how it could be, when changing nothing still causes it to oscillate between broken and not broken.

PLEASE, someone tell me what I am doing wrong because it seems to me like I have to force UE4 to remember my lines of code constantly, and it’s not actually a problem with the code itself.