Download

Random slices/holes in my mesh for no apparent reason?

holesinthemesh.jpg

So…none of my uv’s are overlapping that I know of, I’ve tried playing with the LOD and the camera clipping, etc, but…there are holes in my mesh, and I dunno why! I don’t know if it’s an issue with the FBX export in Blender, though, I’ve tried using other programs and switching things out, and I’m still getting the same result. Maybe I’m just doing something wrong, but could someone help me out, please? There’s no rhyme or reason to it that I can see. Thank you in advance!

Hi csunberry,

Can you post a screenshot of your 2nd UV channel for your lightmap (UV Channel 1) for this mesh? If you don’t have a lightmap UV setup, can you post a screenshot of your UV channel 0?

Thanks!

Tim

No problem! I actually don’t have a lightmap set up, but I have two UV’s, one for the wood, and one for the handles. (The secondary one is just a blank, random colored mat.)

uvs.jpg

I actually redid the UV’s just in case, in case the partial mirroring was causing an issue, and condensed it into one map, but, it didn’t seem to do anything. I had a chair I did recently within the past day or so with the same method, and it doesn’t seem to display the same sort of issues, so, I don’t know what’s going on. (I’ve never had the issue before.)

Thank you!

Thoughts, anyone? Please? Should I post this in the FBX import problems, or what?

It looks like you have overlapping UV’s. Each Face needs to have it’s own space in the UV map in an additional UV channel, so that each faces’ lighting can be calculated independently.

I actually redid the uv’s completely, so everything was completely separate, and I’m still having the same issue. :confused: Thank you, though!

I’m not an expert on this, but I believe what he said is to assign a separate channel for the UVs. If you look in your screenshot on the right, it says UV channels: 2. So try adding each one. Assign channel 0 or channel 1, or whatever you made.

Yea, I actually did that as well, as previously mentioned, with the lightmap and everything, and it’s still doing it. This also happened with some other models I made today, and I made sure they had lightmaps, and no overlapping UV’s, but the same thing happened. I’m using Blender 2.72b; I tried using the newest 2.73a release, but still there are holes.

Check your normals.

Normals are all facing the right way. I’ve put the models into several different programs, and while it’s not UE4, I’m seeing no issues with the normals, or anything else, which is why it doesn’t make sense.

Earlier, I had created a torso. I brought it into UE4—it was perfect, no holes, no problems. I parented the mesh, with no changes to it, to the armature, and suddenly, holes appeared. I did the regular checking; nothing from what I can see.

Does Blender have something like the “Unlock Normals” command in Maya?
Did you try to re-compute normals in UE4 instead of importing them?

Normals, UV’s and the like shouldn’t create holes, they do technically split each vertex up if you split by smoothing group or UV splits…

A issue that is potentially related or perhaps unrelated is that you have split your UV’s correctly but your smoothing groups do no follow the same logic as your UV islands, (everything looks averaged/the same smoothing group), I haven’t used blender, in max you could assign a ‘hard’ smooth to each of the UV island faces, in maya you would do it via edges.

Heres a few things you could try:
Select all vertex and see if you can weld them.
Makes all faces have hard normals.
Have less islands on the UV’s.
Any export options for tagents + bi-normals?

As of 4.7, it actually corrected itself without me having to do anything. Thank you, though!

thanks for this section i am on the 4.18.3 and i have this issue with one of my meshes in unreal engine 4 too .
i have a good uv with good density and everything is like he’s problem except this part when i used low res mesh everything is good but when i use my level 3 mesh with more than 5k poly it will started , when i render it out of the unreal with any other engine it’s ok but when i use unreal engine it has random holes , so it seems that problem he was talking about it and for him was fixed in next update being repeated again .