Random Sequence Player Blend In Time not working?


“Blend Time”, inside “Blend In”, inside the member of “Entries” array, inside “Random Sequence Player Node” in Anim Graph is not working as I imagine. Whatever value I put in there - the time of a blend is same - it jumps quickly from one animation to another (probably blending with default 0.2 second blend time).

I imagine it taking 5 seconds between the animations to jump from one to another when I put 5 seconds in blend time property. The Blend In is described as “when this entry is blending in ontop of another entry”. Rest options (custom curve, interpolation) in Blend In also seem to do nothing. I am not sure, maybe I am missing something important.

My problem is that I do not have perfectly identical animations for different idle poses. In every animation the gun is hold slightly off for example, so I wanted to blend between those. I do not feel like creating 5 different blending spaces nor shuffling animations with “Blend Poses by Int”, as it requires an event at the end of the animation to change the random int.

I believe it is very important node, as it is the easiest and the fastest way to do randomly picked animation (for example idle) in Anim Graph!

Any official confirmation as it is a bug?

Definitely something wrong with the blending. It gets completely stuck if you set blending to zero.

GetRelevantAnimTimeFraction() also not working with the RandomSequencePlayer.
It’s bug.

Was this fixed?

Still not working in OCT 2019

Still not working in 4.25.1

Still not working in UE5.1

Appears to still be broken in UE 5.3.2.

How have you all solved this problem?

1 Like