Random Blueprint-related crashes on Arch Linux

Hi, i’m trying to use the engine on Arch Linux, but i’m encountering a lot of crashes related to the blueprints.
For example, when placing “Wait Delay” after a “OnActorBeginOverlap (TriggerVolume)” it crashes as soon as i step into the trigger volume, it doesn’t crash if i don’t put the “Wait Delay”.

Here’s the full log (a bit long, scroll down):

(The project name is “Pesciul” and the map name is “lol”)

System specs:

System:    Host: kezio-desktop Kernel: 4.1.6-1-ARCH x86_64 (64 bit gcc: 5.2.0) Desktop: Gnome 3.16.3 (Gtk 3.16.6)
           Distro: Arch Linux
Machine:   Mobo: ASRock model: Z77 Pro3 Bios: American Megatrends v: P1.30 date: 05/14/2012
CPU:       Quad core Intel Core i7-3770K (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28013
           clock speeds: max: 3900 MHz 1: 1612 MHz 2: 1899 MHz 3: 1769 MHz 4: 1817 MHz 5: 1799 MHz 6: 1819 MHz
           7: 1861 MHz 8: 1798 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 01:00.0
           Display Server: N/A driver: nvidia Resolution: 211x54
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.1.6-1-ARCH
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 05:00.0
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: bc:5f:f4:54:f9:ea
Drives:    HDD Total Size: 1000.2GB (29.7% used) ID-1: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB
           ID-2: /dev/sda model: WDC_WD5003AZEX size: 500.1GB
Partition: ID-1: / size: 459G used: 277G (64%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A gpu: 1.0:37C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 193 Uptime: 37 min Memory: 4141.5/15947.8MB Init: systemd Gcc sys: 5.2.0
           Client: Shell (bash 4.3.421) inxi: 2.2.28

Well log tells what happened:

Cast of lol_C /Game/FirstPerson/Maps/UEDPIE_0_lol.lol:PersistentLevel.lol_C_1 to GameplayAbility failed

which is wierd, do you do anything with GameplayAbility?

Thanks for the answer, i think i solved for my problem, here’s what I was doing:

In the screenshot i am not doing thing right, later i wired the “ToggleVisibility” to the “On Finish” terminal, but in both cases the editor crashes.

If i use the “Delay” node (the one that i’m probably supposed to use) it works without crashing.

I think this was my fault, but i’m not sure that the editor is supposed to crash, without warnings, deleting all my unsaved changes, because of a possible syntax error in the blueprints, is it?

Hey Keziolio-

It seems to be an issue with the Wait Delay node itself. This happens when calling that node from other locations as well. I have entered a bug report (UE-21051) to investigate this issue. It seems that you’ve already worked out that you can use the regular Delay node instead.

Cheers

Doug Wilson