Ran out of memory when idling with 33% RAM left (4 GB)

I know it kida outdated version (4.10.0), but anyways, it is not the first time happening.
I launched DebugEditor using Visual Studio, minimized editor window and left for a while to have a breakfast.
Approximately it took 1 - 1.5 hours (don’t ask me how is that possible) and when I came back I saw this:

When I was doing god knows what for so long editor had been tried to allocate 2.9 GB, while used 2.85 GB (attempt to enlarge memory pool). Note: I disabled pagefile because of SSD.
According to log, I left scene with extreme particle emitter (named ParticleCube), that spawns 1 million GPU particles per frame every 20 seconds (of course with hitches), what can be seen in log:

And it is easy to see time stamps regularity:
22.02 - Spawn;
22.22 - Spawn;
22.42 - Spawn;
23.01 - Crash;
GC is turned on with 30 sec period.
Most dangerous things in UE4 are used: Light propagation volume, distance fields shadows, vector fields (that’s why there is 1 million particles, looks awesome),
This is ol’ good… bad problem with particle system memory leak. I didn’t found fixes of this problem in 10.0->10.4 hotfixes so possible it can even exist in 4.11 also.
I think I better check that by downloading 4.11 preview.
Particle system as is:

Hello HungryDoodles,

Before I set up a repro and wait it out for about an hour, I want to be sure of a few things. What is the lifetime on these particles, as in how long do they last? Could you either provide the particle system itself in a small sample project or list off the settings for the particle system? When you left the editor for an hour, was PIE happening or was the particle system in the level? In what state was the editor left in? What are the specs of your system, mainly GPU, CPU, and RAM? A dxdiag would do in that regard.

It is infinitely looped particle emitter with particles lifetime from 15 to 20 seconds. Burst happens every 20 seconds (Emitter Duration) with 1 million particles each. In addition there is also spawn rate set to 100. Everything else is mostly defaulted or it’s value not affecting particle spawn or lifetime.
For sudden reason this problem is gone. Maybe it’s because i’am finally installed 4.10.4, but I didn’t found anything about this heap overflow in release notes. I’ve just lowered emitter duration to 1 as well as particle lifetime and waited for 10 minutes: not even a byte was lost.
Editor was in default state as it just launched, there was even no clicks (but the one that minimized the window). I’am always using my default level where this particles system appears. Usually in the same case scenario, when I minimized editor and started doing anything else in about 1-1.5 hours visual studio shows up with “Ran out of memory” trigger.
Sorry for bothering, I probably should have been update engine first. If it problem will appear again I will bring maximum info if it will be possible.
Just in case: DxDiag