Rama's Vertex Snapping Plugin w/ modifications: I can't delete BSP stairs


I can’t delete, move or modify my BSP stairs. In the details I can “select matching brush” when a face is selected, but it refuses to delete. It doesn’t really behave like a BSP anymore. Just stuck in the world. I have a couple other spiral stair BSP’s that are giving me the same problems.

When I create a new one I get real options and can delete them. Not sure how these old stairs got orphaned the way they did…?

I’m sure I’m overlooking the simplest thing…

Use this key to delete contents in the engine.


Have you tried rebuilding map geometry? It’s possible the brush has been deleted, but the actual geometry has persisted.

Tried that with no luck.

If I right-click and go to “Edit”, I’ll see that “Delete” is grayed out and “Rename” is as well because it doesn’t exist in the scene outliner.

I haven’t touched Unreal since 2007, wasn’t there a “clean BSP” option?

This is somewhat unusual, I don’t think I’ve seen it before. Can you select it in the editor and post a screenshot (including with the properties window)?

Hi Muhroads,

Are you in selection mode in the panel in the top left? If so, are you able to reproduce this in a new level or new project? I would be interested in the repro steps if this is the case for testing and potential bug submission.

Can you also attach a screenshot of the editor window to see if there is something that stands out that?

Thank you!


okay I found it in the scene outliner. When I select all, I assume the whole world is supposed to be selected. It is. When I hit delete, everything goes away except the BSP stairs. After I do this, I DO see the offending BSP items in the outliner now. They exist twice. One is orphaned and in the way with nothing in the outliner on it while the other can only be selected in the scene outliner.

The orphaned one that only exists in viewport has two panels in Details. Geometry & Surface Properties.

What is the fastest way to upload a screenshot these days? Something with a local client?

We have done a couple things to the engine.

  1. We installed Rama’s vert snapping plugin because we need it.

  2. We modified so one object can be grouped instead of needing two or more. Did this because there doesn’t seem to be a way to center the pivot on a mesh.

  3. Rama’s plugin was modified so vert snapping worked with groups.

When I remarked out Rama’s plugin from the .ini file, the problem still persisted though. It doesn’t select its proper association in the outliner, just an orphaned version on top of it.

You can attach a screenshot here by using the insert image button when typing a reply/comment.


Same here.

When selecting the stairs, only the faces are selectable. They also do not show up in the 2d view ports or the scene outliner.
Screens are a little confusing, so I have attached 2. First is with the stiars selected, second is with another brush selected (for reference).

Hi MuhRoads,

I’m actually not sure on this one. I don’t have any of the plugin’s installed on my UE4 installation. I’m also not a programmer so when it comes to modifying code and such as you’ve done and some of the things it affects I’m unfortunately at a loss.

To better serve your question I’m going to retitle this post and move it to the “Engine Source & GitHub” section to see if someone there can assist you as this seems more likely related to Rama’s vertex snapping plugin. He may be able to help you look at the issue as well.

Thank you!



my plugin version has not changed in months and does nothing with BSP :slight_smile:

Having the option do delete things being greyed out has nothing to do with my plugin, but I am happy for discussion to continue in this thread until the issue is resolved.

But I haven’t the slightest clue what the issue might be :slight_smile:

Good luck!


PS: curious that this only happens with stairs? No other BSP shapes?


Hi Rama,

Didn’t you just implement vertex snapping for BSPs into your plugin? This is why I mentioned you could potentially give him a hand. Muhroads indicated they were using your plugin that was modified. With the recently BSP snapping you had completed I figured you may have an idea.

Thanks for any help you provide!


Oooh I see, I thought there was an assumption being made that my plugin was causing the BSP issues, but my plugin has not changed in months, all of my work is on the actual Editor Integration that is on Github and will be in a near future Engine release :slight_smile:

As far as the issue itself, I find it very odd it is only happening with stairs.

So my question for MuhRoads,

  1. are you still having this issue

  2. is it true that its only happening for the bsp stairs?


I’m not sure if it’s related to Rama’s plugin also. From memory I had this problem before installing the plugin (which I have also currently switched off in the preferences. Sorry Rama, I couldn’t seem to get it to install correctly).

Hi SuperNovaBen,

Do you remember or can you still replicate the issue without the plugin? I’d be curious of the repro steps if it’s possible. I had another user post this morning in the Content Creation section having the same issue but I’ve not heard back from them yet.

With this user having a plugin that I don’t have in my internal build and having modified Rama’s code for their specific use case I didn’t feel I would be helpful in reproducing when I do not have the same setup.

If you have the steps that would greatly help me in figuring out how to replicate and report this bug! :slight_smile:

Thank you!


I managed to replicate it just now as follows.

  1. Edit the stairs width with the standard geometry editor (Rama’s are dissabled in the preferences)
  2. Edit the stairs with all the brush settings parameters (step length, height, width, number of steps and add to first step)
  3. Build geometry for current level
  4. SAVE and CLOSE the editor.
  5. Restart. et voila, some broken bsp stairs in the map. The bsp in question has no ‘brush settings’ in the Details tab from this point on. Unlike regular stairs, which do have.

But, I couldn’t replicate it again… Which is pretty darn annoying.

The map I was using was the Example Map in First Person Template, with some extra geometry thrown in there, but no other stair brushes. Editor version is 4.02
Hope this helps.

Hi SuperNovaBen,

Thank you! I’ve been able to replicate it. It seems to be related to using the Geometry Editing mode then saving and closing as you’ve suggested. I’ve only gotten it to do it with a couple of the brushes. I’m going through now to see which ones it affects.

Thanks for the feedback!



I did see (not sure if it was mentioned before) that I can still delete the BSP from the scene outliner. I have to right-click > Edit > Delete to get rid of it.


You might be right about it not being every time. I replicated it twice in a row with different brushes then posted here to confirm and have not been able to replicate it since. I’ve repeated the steps 7 or 8 times now. :slight_smile:

If anyone can replicate it every time please list the steps here. Thank you!

I’m not using any plugins. I’m using the released build 4.1.1 from the Engine Launcher.

I had this same problem with spiral staircases. I could see them in all view-modes but wireframe. This applied to perspective and ortho views.

I did the trick listed above of deleting everything else in the scene and stairs showed up in the Scene Outliner and was able to select and delete them from the list. I noticed their name was now curved stair brush and not Spiral Stair Brush. This may have been due to changing the brush shape at some point when I first placed it a couple days ago, but I don’t remember. I do know that I had originally placed a curved staircase but thought I had deleted it and started over in the same place.

After undo-ing all the deletes and restoring the scene, I was able to type in the name ‘cur’ into the search field in the Scene Outliner and this filtered out everything but the curved staircase brush. I could select the staircase within the Scene Outliner list, but only 1 appeared at any given time within the list. I was able to delete with the delete key and also by the right click menu and choosing edit>delete (previously ‘delete’ was darkened out in the right click menu). I deleted 6 stairs despite only having 3 that were placed. Maybe they are duping and orphaning at the same time?

Other things I noticed/things that may be relevant in finding the bug:
-The curved stair brushes did not have the “Brush Settings” category on the Details Pane. Infact, only Geometry and Surface Properties were visible in the Details Pane.
-When selecting the curved stair cases in the viewports, I was only able to select one face. It would not select the entire brush.
-There were no additive or subtracted brushes that intersected with any of the stairs. There was an additive brush and a subtractive brush that were flush against the bottom edge (subractive) and the side face at the top of the stairs (additive).
-I had modified the brush settings after placing the first stair (increasing angle of curve and number of steps). The additional two copies of the stairs were duplicated by alt+drag moving straight up on the z axis. Edit Geometry was not used on the brushes but may have been active at some point when clicking on or around them.
-The stairs showed no indication of being broken until selected or changing to wireframe view. They collided properly and received light. I don’t know if they had shadow issues as I was using temp lighting and wasn’t paying attention for any shadow issues.
-That stair were unmovable, either by brush selecting (only on face would select) or in edit geometry mode.
-During the course of the map, there were point lights that were added within the middle gap of the spirals. After removing them the stairs still acted stuck.

So I’ve had a similar problem where not only stairs, but any any overcomplicated piece of BSP after saving and closing. Not only can I only select faces when clicking the BSP in the viewport, but trying to copy or even center focus with the ‘f’ key are impossible.

That said, I did come up with a very peculiar solution: Select the BSP in the scene outliner. Alt move the object to create a duplicate. Now you can select the duplicate AND the original as normal. Then you can delete the copy and continue with your work. I don’t know if this solution is permanent, but it might just be a bug that needs fixing. Let me know if that works.

Thanks for sharing your solution!