Ragdoll is shaking

I have a reasonably simple skeletal mesh, a plush bunny. I set up the physics asset for it but during simulation it keeps shaking for no apparent reason. I made sure that the collision hulls don’t collide with any other in the vicinity. Restitution is 0.05. I turned on reprojection and lowered its values. Tried angular orientation drive. Still, nothing helps. Any ideas what else to try/check?

Interestingly in zero-g simulation the skeleton spreads out, the bones move some distance from each other… yet in the skeletal mesh editor everything deforms as expected. In Modo, where the asset was created, both the root bone and the deformed mesh has default transformation.

I deleted everything in unreal and the skeleton in Modo and started over, now it seems the issue is gone. The asset was reimported a few times as I massaged smaller issues with the skeleton and the bone weights, maybe something was not updated properly.

Hi Zoltan,

I notice this when I duplicated a physics asset from another mesh (based on the same skeleton)

I think it’s an engine bug

So creating each physics asset from scratch seemed to fix it to me.


Hi ZoltanE! Try to change settings for capsuleComponent… It may interfere with that of the skeletalmesh .

Thanks, I’ll try it when I run into the issue again.