Ragdoll flying crazy

When i enable the full body simulate physics, the character will fly and spining like crazy just like the video below.

I not sure what factor causing this problem because it is not happened at the beginning.But this is the only character (Kwang from Epic’s paragon)have the issue and i already try to recreate the physical asset or use the default physical asset from Epic, try to change the character mesh collision present to ragdoll or physical body, disable the clothes physics simulation and disable the impart base angular velocity in “character movement” which mentioned by other answer . I spent whole day to try and search the solution still can`t fix it.

This usually happen when two physics driven entities interpenetrate but are not allowed to move away from each other. For example the collider capsule in the upper arm and the one in the lower arm overlap and they are allowed to collide with each other. The physics engine then tries to apply forces to them to move them apart but the constraint between tries to prevent just that and so chaos ensues.

The first step is to narrow down which component is the culprit: is it the skeletal mesh? Is it the cloth? Is it some kind of attachment like a weapon? Try keep turning stuff off until you see a change in behaviour.

Another place where these sort of bugs can fester is the physics asset for the character:
Make sure that there are no tiny colliders lurking deep inside other colliders. The skeleton tree panel is a great place to check for colliders in unexpected places.
Neighbouring bones should not collide with each other. Depending on your gameplay and animation needs exclude as many nearby bones from collision as possible. (Select a bone to see non-colliding other bones in gray.)
Double check if all constraints are set up properly. A sleep deprived developer’s stray click might turn a ball socket joint into a motor providing a mind-bending puzzle for next day… as it happened to someone I know… :wink:


Problem solved! Thank you very much! I follow your advice step by step and disable collision between closest bodies then I realize it not affected by the collision. I check all the attachment on character blueprint and found one little attachment is very close to the body and collision setting is block all dynamic, so when the character simulates physics, the little attachment will keep pushing the physics body and cause the issue. A little thing causes a lot of time to fix…lol…

Also wanted to say thanks for this answer. I was struggling with this forever.

Thank you Zoltan !
It helped me as well… There was a sculp mesh attached to the head bone of the skeleton to preview hair groom. The Collision threw my skeletal mesh to outer space every time I started simulating the head and I didn’t understand why for quite a while.
Now it’s working.
Muchos Gracias ! ! !

1 Like

Thank you! the peview meshes causing all the bug. Deleted all preview meshes it just then fixed the issue