r.setres 1920x1080f behavior is inconsistent with r.setres 1920x1080 & fullscreen commands

It’s quite possible this is just user error on my part but it was my understanding that the console command “r.setres 1920x1080f” was supposed to be identical to using the two separate commands “r.setres 1920x1080” and “fullscreen”. However, using the single command from Standalone Game in the editor causes the frame rate to lock with the monitor’s native refresh rate and ignore the configured frame rate options in the project’s General settings.

When the “f” is omitted and the fullscreen command is ran separately, the frame rate returns to the desired framerate of the project settings.

Is this intentional?

Repro Steps:

  1. Open Project Settings and click on General Settings.
  2. Set use Frame Rate Smoothing with 90FPS min and 200FPS max. Set target FPS to 90.
  3. Play from editor as Standalone game.
  4. Use console command “stat unit” and take note of the current frame stats
  5. Use console command “r.setres 1920x1080f”
  6. Validate updated stat unit values.