Download

r.ForceLOD Console Command not working on Android?

Hi all.

I am using the Console Command “r.ForceLOD” via blueprint in the beginning of my level. I have 2 LOD levels in my game, where level 0 is the high-quality models, and level 1 is low-quality model. When the user select Low Graphics Options in the settings, I execute the command “r.ForceLOD 1” to force only use of the low-quality models. Else, I use “r.ForceLOD -1” which disables the forcing, and the LODs are then adjusted according to screen size. (see image)

This works perfectly on Windows and IOS (tested on Ipad 2020 model), but it will not work on Android. I have tried on my Samsung S20 Ultra and Galaxy Tab A7 Lite.

The LOD is always adjusting to screen size (which is default), it will not be forced to the low-quality LOD when Low Graphics Options is selected.

Could it be that “r.ForceLOD” command is simply not supported on Android? Or am I missing something to use it on Android?

Using UE 4.27.2 and Android version 11

Well, since there was no response on this thread, I did this another way. I used the Force Lod node on the actor when it is created, and now it works. It could be that it was not working because the object was not loaded when the command was sent? Strange that it worked on Ipad earlier… maybe it loaded it into memory faster than Android. Anyways, problem solved :slight_smile: