Quixel Megascans Asset Keeps Asking me to Select a Socket

Greetings awesome community,

I’m very new to Unreal Engine, and I downloaded a Megascans asset called “Grass Clumps” yesterday (Among many others).

Since then, every time I open the content drawer and double-click the Grass Clumps asset to open its settings, the window that pops up has an empty right sidebar and the words “Select a Socket” as seen in the screenshot attached below.

Before importing these assets, the other assets I had were opening the settings without asking me to Select a Socket. But now they are also asking me to “Select a Socket”

Please help me understand what’s wrong. At the moment, I’m unable to edit the grass and almost all the other assets.

Hey @MonteroKirilenko, welcome to the Unreal community!

It looks like you have the details panel closed when editing static meshes, so you are defaulting over to the socket manager. Click Window on the top toolbar and see if there’s a check mark next to Details; if there is not, go ahead and click that. You can also go to Window > Load Layout > Default Editor Layout if you ever close a window and need to get it back.

I hope this information helps!

1 Like

Hey @anon78826165,

You are 100% right!

It seems I had closed the details panel while tinkering with the workspace earlier.

After going to Window > Load Layout > Default editor Layout, I can now see all the settings I was looking for.

I can now finish my project.

Thanks a lot for your valuable suggestion.