Quixel Bridge UE Crash

When I tap on any object in the bridge app my screen goes black and this only happens when I am logged in to my account. If I log out of my account I can click everywhere and everything is ok, but of course I can’t download anything.
I have tried reinstalling the Bridge plugin and Unreal Engine , but nothing helps.
I use unreal engine 5.3.2 and latest Bridge plugin.
Any idea how to fix it?


*same issue,it almost drive me crazy since six hours ago *

1 Like

man this happens to me too, i emailed support, they asked me to provide screenshot but no response since 3 days ago. glad i’m not the only one.

Same. And it happened to me in a class full of students when my class was supposed to be based on this feature. Now, at home it’s still the same. Help! At least 20 PC had the same issue at once.

Edit: it is still doing this but I found that if you won’t open the material but just use the little download icon on the right corner of each material it works! Hope that helps a little.

This issue caused a major problem for me. Plus I cannot access my metahumans from my 5.3 projects. But when I created a fresh project in 5.4 it works. :thinking:


Bridge Clean Re-installation

  1. Ensure that Bridge and Unreal are not running.
  2. Navigate to this path on your machine - C:\Users[Username]\AppData\Roaming\Bridge-Bifrost. (Please note that AppData is a hidden folder)
  3. Delete the folder named - Bridge-Bifrost.
  4. Launch the Epic Games Launcher.
  5. Navigate to the Library tab and select the current Engine that you are using.
  6. Under Installed Plugins find Quixel Bridge and ensure to Remove it.
  7. Close the Epic Games Launcher.
  8. Navigate to your Unreal Engine Installation directory. [Path to Directory]\UE_5.3\Engine\Plugins
  9. Here, locate the two folders named “Bridge” and “MegascansPlugin”.
  10. Delete both of these folders.
  11. Back in the Epic Games Launcher’s Library tab, scroll down to get to your Vault.
  12. With the current engine selected, click install.
  13. Once installed, please open up a New Project.
  14. Select Quixel Bridge and sign in to export assets directly to UE5. Let me know if this solves your issue.