Quixel bridge not downloading assets

Hi,
I started using Unreal two day ago, but I have an issue with it.
It doesn’t let me download assets from Quiexel Bridge.
It stops at 100% download, but it doestn’t stop or allows me to add it.
What shoud I do?
I already have an acount of Quixel Bridge, and I also tried to uninstall it and install it again. Sorry if it wasnt understandible, English is not my first lenguaje.

1 Like

Hey there @TwAliceAttack! Welcome to the community! Your English was great! This post from the Quixel forums has helped most users that come across this issue.

1 Like

I cannot find anything useful in this post and I have the same problem at the moment, Bridge is not allowing me to download any kind of asset

1 Like

Hey there @gian9315j! Welcome to the community! What version of the engine are you running? At which point in the process does the download fail?

I am having this same problem and it is frustrating as i am new to unreal engine 5 (and computer game dev in general) so its not letting download assets that the guy is using in the tutorial i am watching. Download will either get to 100% and hang, and not let me add it or it will go past 100% and just keep going. maximum i got it up to at one point was like 350%, then decided to just quit the whole thing. Again, it doesn’t let you add the asset when it over downloads in this manner

1 Like

Hey there @Dori2190! Welcome to the community! So the download percentage just continues growing indefinitely? That’s interesting!

Which version of UE5 is this occurring in?

Do other versions bridge plugins work?

After uninstalling and reinstalling the plugin in the launcher, does the issue persist?

Hi, i got the same problem. I’m using Quixel Bridge 2023.0.7 version.
The download pauses indefinetly at 100% but it doesn’t finish the install. It works well after first install but i decided to move the Megascan folder into a disk with more space, after that move Quixel Bridge problem starts. I have uninstall and reinstall it but nothing changed. Any help please ?

I reinstall it again, now it goes over 200%, it looks like there is no limit anymore.

Hey there @KPTNDOX! Welcome to the community! If none of the solutions from the previous thread listed above assisted you, I’d recommend making a report on Quixel’s side here:

You’ll have to log in with your Epic Account to access the form.

i had the same problem after update to 5.3.2

1 Like

i had the same problem after update to 5.3.2

i had the same problem after update to 5.3.2

Same problem here, latest bridge version, UE 5.3.2.

Hi, try downloading separated Bridge app on Quixel Bridge - Manage 3D content and export with one click and run it, don’t use Bridge plugin on UE5. I tried and it worked for me!

Hi, I have the same problem with the latest version of app downloaded from your link

Had the same problem just now, UE 5.3.2, Bridge plugin 2023.0.8. It was NOT the case when the download progress goes over 100%, but the one OP describes: Dl progress reaches 100% and gets stuck. I could click “Add” button, but only an empty folder was added to project.

After a moment, I noticed I was silently running out of space on the drive where Quixel was set up to keep the library. Quixel did not report that, just got stuck at 100% instead. After moving the library to another drive (first I set the new path in the settings, then manually moved the library on my disc, including the .json file), clicked “Redownload” for the assets that failed do download before, and now everything works.

Maybe it will help at least someone with this issue. Not everyone though, cause I can see here some of you already tried moving the lib and it broke it even more :slight_smile: So not a universal solution, but check your drives just in case.

2 Likes