Download

Quixel Bridge failed Materials in UE5

Whenever I download and import any 3D assets from Quixel into UE5 via the new native browser, the assets render with a grey prototype texture. The problem seems to be that they are downloading with a Material Instance and the associated texture maps that are correct, but the MI for the mesh has no parent Material.

2 Likes

same Problem here

1 Like

I’ve had this same issue. For some reason, it won’t automatically create a master material if one doesn’t exist, and since it doesn’t have a reference for the material, it just creates a blank mat. The sample project (Valley of Ancient) has a copy of all of the quixel master materials, so you can just migrate them all from there, then try reimporting. That worked for me, it’s just a hassle, since every time you create a new project, you need to migrate the materials over.

2 Likes

Actually what’s worse is, the plugin itself has all of the master materials included in it’s content. If you show Plugin content in your CB, scroll down to the Bridge plugin you can find them. They are a little different from the ones included with Valley of the Ancient too (a little newer). The plugin has all the materials and just won’t use em’ lol

1 Like

@rdtg, I discovered that after posting my question, and that’s how I worked around the problem here.

@dragonlordsd, Thanks for the tip about VotA having those master materials. I hadn’t yet downloaded that sample project and hadn’t thought to look there.

Hi everyone, are you experiencing this issue with fresh UE5 projects or on ones that have been ported over from UE4 to UE5?

I don’t speak for anyone else, of course, but I have not yet migrated any projects from UE4 to UE5. So to answer your question, I have reproduced the problem with a fresh project in UE5 (and only in that context).

I’m experiencing a completely different Quixel Bridge Fail in that, when I import a new material, the channel-packed texture is set incorrectly, so I have to manually change it to “mask” in the texture settings other wise it will not look right in a PBR context.

Hello, I also encountered the same problem. Do you have a solution?

I got no Material in Bridge (UE5), too :frowning:

Has anyone figured out how to fix this? It continues to be an issue with UE5. I believe UE4 has a settings to import master material but UE5 does not?

those settings are suppose to be like that by default the Materials are to OVERRIDE the existing Master material it will create

I posted this in a previous thread. It seems to be a bug with the internal bridge. I believe it was fixed in the most recent update?

If not, you need to migrate the master materials from a project that already has them, such as valley of the ancient?

I’m using the latest build but it still has the issue. But creating / importing a master material and applying it to each material instance did fix this. Thank you!

Weird. I had this exact issue up until the latest update, and I haven’t had it since. But glad it worked out for you.