Quit game does not exit android game in 4.22 (it was fine in 4.19)

I migrated my game (The Big SokoBang) from 4.19 to 4.22.

The unpleasant surprise is that now Exit does not work - I am using it on Exit button with blueprint “Quit Game”

Any ideas what to do ?

PS: I tried both true and false values for “Ignore Platform Restrictions” - none works

This is happening to my app too !

after 2 week affords to solve the problem … there is no solution. How can I ask the engine developers?

Anyone not having this problem in Android+UE 4.22 ?

Yea, i would like to know too, if someone has explanation, is this in purpose?

I’ve been having the same Issue on 4.22 and just did a build with the latest update (4.22.1) and the quit game function is still broken. Pretty frustrating.

Ok. At last … Unreal Engine Issues and Bug Tracker (UE-72276)

Unfortunately the fix is not included in 4.22.2
I hope 4.22.3 comes soon

don’t work 4.22.3

Yeah still don’t work at 4.22.3

Try using timer to call QuitGame in 4.22. Works for us.

I had the same Problem. Make sure you tick/enable “Ignore Platform Restrictions” in the “Quit Game” Node. That made it work for me.

Ignore Platform Restrictions is disabled in shipping builds, thus not a good solution.

I succeeded in using FPlatformMisc::RequestExit(false) in 4.22.3. If you need a blueprint node you’ll need to a create a blueprint library c++ class and add this function

UFUNCTION(BlueprintCallable, Category = "Game")
static void MyQuitGame(bool bForce)

and then you can use the MyQuitGame node in BP.

Force quit skips things like saving changes to the config and other teardown handling so generally you don’t want to force (though I use it when enforcing entitlement checks).

Soo, no one bothered to report this bug to the official bug report system ?!

I just submitted this bug to Epic.

It fixed in the 4.23

I have the same problem on 4.27.2 too!!!
Any solution or is necessary report it to Epic?
Thank you