Download

quick test with modular assets

Modular corridor, took about 2 days to make ( being lazy lol) the character is one I made a while back, pretty impressed with how everything looks right off the bat, it’s like you don’t even have to try hard in unreal engine 4, it just does everything for you :slight_smile:
https://youtube.com/watch?v=QwYyLIBmLPM

The style is pretty cool but it’s just a bunch of shiny black with some emissive glows at this stage.

I would like to see it when there is more going on but it’s a good start.

And i agree, UE4 is very easy to work with! So far the best SDK i have used and I’ve developed with just about every engine SDK since the original Hammer for Half Life…

For 2 days that looks pretty amazing!

yeah well I was kinda going for a metallic sheen with emissive lights, definatley gonna add more to this, I’m having so much fun just playing around, and I haven’t even touched the animation blueprint yet, gotta get him doing some moves :slight_smile:

thanks draquod, glad you like it :slight_smile:

I love it, the whole black/lights works. Interested to see where you go with this. =)

great start :slight_smile: I was wondering is your fps really bad or was that just during recording?

Thanks man, thinking of adding some doors at either end and maybe a big engine room, with some kind of machine with moving parts, have a rough idea we will see how it goes

yeah it does kind of seem that way :), I’ve actually been having a problem, I have two graphics chips the NVidia one and the integrated intel graphics, I think it switches back to the intel one when I play in new editor window or standalone game, don’t know how to fix it, asked on answerhub but didn’t get an answer. :frowning:

You should be able to set which graphics card UE4 uses in the nvidia panel I believe. And are you sure it is your graphics switching and not your rig? What are your specs? If it isn’t high end you may need to adjust the scalability, switching post processing and anti aliasing to medium helped boost my fps quite a bit. Answerhub doesn’t seem to get a lot of attention, so I feel your pain. =p

Info on scalability: https://forums.unrealengine.com/showthread.php?1177-How-to-Improve-Frame-Rate-Through-Video-Settings

didn’t even know about the scalability options :), thanks! yeah messing around with scalability seems to improve performance, what I find is weird is that in the editor window then game runs smooth as silk, but when I run in a separate window or standalone game, it tears and lags bad, that’s why I thought it was switching the default graphics chip

thanks for the info on scalability was just messing round with it does seem to help, but it makes the game look pretty bad lol

Glad to hear, if you’re getting better performance in the editor window it’s probably due to the resolution difference between that and the popup. If you go full screen for example you will dip a bit in framerate. There are some options that even if you tweak, it won’t affect performance much, but will affect visual quality. You have to play around with it to get a good compromise between visuals and performance. For me personally, switching the AA to medium, and post process to medium did the trick. There’s hardly a noticeable difference. Play around and see what works for you. =)

I’ve created a procedurally generated corridor with adjustable length, swappable wall meshes, and the ability to cap either end with either a door, a right or left turn or a split. next thing I’m gonna be working on is a procedurally generated room, once I have that done, I’m going to add the two together and generate a maze type thing :), here’s a video of the progress so far, keep in mind this doesn’t look it’s best as I had to turn down some of the settings in order to get it to run reasonably smoothly, also I need to make a few more meshes for parts to make things more interesting looking, also spread some random stuff throughout it in order to give a more varied layout.

https://youtube.com/watch?v=eYL53_SszQY