Download

Quick Start Programming, cone doesn't move

Hi.

Fresh here at UE4, I dived into the Quick Start Programming tutorial to create a cone that hovers over a table. Everything went smooth until I tried to add a UPROPERTY macro so that the scale value of the bobbing can be edited from the editor. Now the cone does not move at all and guess what, I remove/comment out the code I added and the cone still doesn’t move.

Can anyone help me here? I’m totally lost about this. It’s even reproducible, did it twice. As soon as I add the UPROPERTY macro and new variable the cone doesn’t move anymore.

Steps to reproduce:

  1. Do all four steps here.
  2. At step five, introduce the UPROPERTY macro + new variable to make scale editable in the editor.
  3. Cone doesn’t move anymore.

I’m using the lastest engine which to this date is 4.7.5.

I’m also going through the tutorials and I had this exact problem. There’s two things its likely to be.

Restarting the editor. It seems Unreal does not properly recognize UPROPERTYs until you restart the editor.

Check in the details panel that base component hasn’t lost its transform section. If you are adding the static mesh component (cone) to your object in the editor the base (floatingactor1) component will inherit the transform of the child component. This transform will get lost sometimes when it hot reloads, making it unable to move. Add a second static mesh component and then delete it. This should restore the base objects transform section and allow it to move. This doesn’t happen if you add the component in the C++ code which you get to in a later tutorial.

I can confirm that adding a second component (cube in this case) and deleting it results in the cone moving again. Restarting the editor did not help.
Thank you!