Download

Question regarding Texture Quality

Hi, So I am currently working on a level for my final project in college. I am going for a hand painted style. I am however having one major issue that is really irritating me.

My textures in photoshop look sharp and crisp, if I load them onto my model in 3DS Max I am getting similar results. However, in Unreal the textures are blurring. Now, I have asked some of my classmates and they don’t notice it. However I really notice all the fine details that I am painting in are disappearing.

Is there some setting I am missing? I have tried searching for a solution but I seem to only be finding results that deal with blurry textures, they are not exactly blurry, just of a noticeably lower quality. I thought early on it might have been caused by texture stretching or other distortion but I have since corrected all my UVs so it seems to be an engine issue.

It could be due to the format that UE4 is storing the textures in, Can you post pictures/screenshots of the texture in UE4, Max, PS ?

Thanks for your reply!

Here is what I am currently working on.

112bd7755a62fa85b267c32f97dd0fd8e2ef8f63.jpeg

The colours just look really washed out and blurry, its happening to all of my textures no matter what file format I save them as. I am sure I am doing something stupid or its just set to a low setting, my Unreal experience is quite limited. The textures are all just applied as an albedo.

Is the texture set to use sRGB ?

Have you tried exporting the texture as Targa(tga) from PS and using that inside UE4?
Is the image exported from PS the same resolution as in PS?
Does the exported image look sharp when viewed (in PS)?

You could try setting the UE4 texture format to BC5 (D3D11+)

A bright light near the surface could cause it to become “light”.
You can try rebuilding the lighting if it is giving warnings about unbuilt objects/lights.

HTH

Yup, RGB 8bit.

Targa has the same results Im afraid. PSD, Jpeg, PNG, Tiff all have the same effect.

Yeah

It does indeed.

I seem to only have the option of a BC5 normal map? I tried setting it to HDR but it just completely desaturates the texture on the model.

No lights near the object or even directly illuminating it

No errors in regards to this particular object. Removing the objects with errors doesnt have an impact.

There is a check box called “sRGB”, It colour space that the image is (supposed) to be in.

Sorry, It is actually BC7.
But it sounds like that will not be a solution(Even if it works, The min GPU spec would be a little prohibitive).

Is the texture connected straight to the “base color” node of the material? (Just checking to see if there is not some other node that is affecting the output ).
Does the image look sharp in the material preview (you can first try a square and then use the teapot icon in the view to set the preview to use the currently selected mesh)?
The only other thing I can think of at this time is to try the image in another project, Have you tried applying the material that uses it to a flat surface?

Yeah sorry, its ticked.

BC7 makes no difference to the amount of noise in the image.

It is indeed

No, there is quite noticeable noise in the image. When I reimport the image from the source file it goes to how it should be but the compression is causing a large amount of noise so I guess it is down to the method of compression of the image file. Is there anyway around this?

It is the same on a flat surface.

The compression is definitely affecting it. One thing I cant seem to comprehend is that before it is compressed the image is 87381kb, after compression it increases to 10923kb. I assume the colour loss is due to the sRGB clamping the colours of Photoshop’s RGB. Anyway around either of these issues?

It may be a MipMap issue, The only way I know of to check that is to tell the Material texture sampler to use mip level 0.
Does the image asset look sharp/okay in UE4?
The last thing I can think off is to check the dimensions of the texture in UE4.
You could export the image from UE4 by right clicking on the asset and then under “asset options” (if i recall correctly) and that should give you a Targa you can view in PS.
And now I am stumped.

Is this the only texture that is exhibiting this problem?

HTH

The MipMaps seem fine, they scale reasonably well to 13 but the starting point is just too noisey!

The asset is fine and everything seems ok there.

Dimensions are fine, 4096x4096. Its just when it starts to compress I can visually the artifacts and the pixelation of the image.

The exported Targa, strangely enough looks fine in Photoshop so I really am confused.

Every single texture I have painted is the same.

This will incurr a large memory footprint, but what happens when you set the texture compression to “UserInterface”.
The texture will be stored (nearly) uncompressed. If it still looks dull, then its not the compression…

What colour space are you using in PS?
That may be the issue, Can you double check and or maybe use the PS colour space conversion tool to test that.

I have had it where I have accidentally exported some images in ProPhotoRGB instead of sRGB and they result in a look kinda like what you are getting.

HTH

You are comparing runtime vs offline memory footprints. UE4 use texture compression that allow textures to be stored on gpu with 1/8 of memory footprint of raw texture(like bmp). Compression like png has to be uncompressed before it can be used by gpu so it will actually use a lot more memory that the storage requirment would imply.