Download

Question on how to make a holdable item/weapon in ARK Dev Kit

Hello everyone,

As the Title may spoiler, i am very interessted in making some new items and weapons wich you can hold in your hands. I already made a 3d model and saved it as an fbx formatted file! I also created a new folder inside the mod directory of the System Explorer inside of the Ark Dev Kit and imported the fbx model in the folder!

Now is my Question : How do i actually get in in to my Players Hand?

I already googled days and searched all possible forums (including this one) but i couldn’t find anything regarding on how to make : a new gun / weapon / carriable item and so on…

So i started this thread in the hope to get an answer on how to accomplish this!

Thank you for your time ! FyZ1K

Here, check this little video out. https://www.youtube.com/watch?v=ods3drEXaAA
He walks through something basic like an axe.

Hey CFrankie

Thank you for your quick answer!

I will look in to this asap and i will let you know if it worked for me! Allthough i allready saw this one and he is using MAYA… I am using an old version of C4D and i am curious that i can’t get this bone hierarchy managed in my old grey version :stuck_out_tongue:
Btw i am no pro so it might take a while untill i figured it out. But i will post my results here if i get any…

To let you know what i am up to:

My Plan is to create a remote control which you can use while riding on your dino to open gates remotely… If i get it to work with the mesh, i might need a little help regarding the call of the remote code input screen after clicking with the custom remotecontrol in the players hand :slight_smile:

Any help on this would be BADASS! Sorry my choice of words but this is my enthusiasm speaking :wink:

A BIG THANK YOU for any further help! :slight_smile:

Hi again, ok so i imported the mesh from Cinema 4D to the Ark Dev… The Structure seems to be well declared allthough i had no problems importing my asset as shown in the video which you mentioned in your earlier post! I also have gotten the same animation structure as you do… But how do i actually get my “copied hatchet” as an engram in to the game and then in to the players hand?

I ran a Debug Session but i couldn’t find anything through the game… Can anybody tell me where to find the engrams?

Thanks!

Sorry for Bumping…

I finally got my item as an engram to work and i can build it and place it in the quickbar…
But when i’m trying to select it during playing i am then receiving error messages…

Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000040

UE4Editor-Engine.dll!UnknownFunction (0x000007feda53fc75) + 0 bytes [UnknownFile:0]
UE4Editor-Engine.dll!UnknownFunction (0x000007feda53fbe9) + 0 bytes [UnknownFile:0]
UE4Editor-ShooterGame.dll!AShooterWeapon::PlayWeaponAnimation() (0x000007fecfb02148) + 0 bytes [d:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shooterweapon.cpp:1431]
UE4Editor-ShooterGame.dll!AShooterWeapon::OnEquip() (0x000007fecfb01847) + 0 bytes [d:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shooterweapon.cpp:361]
UE4Editor-ShooterGame.dll!APrimalWeaponGPS::OnEquip() (0x000007fecf9f022e) + 0 bytes [d:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalweapongps.cpp:137]
UE4Editor-ShooterGame.dll!AShooterCharacter::SetCurrentWeapon() (0x000007fecfa2247b) + 0 bytes [d:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shootercharacter.cpp:1351]
UE4Editor-ShooterGame.dll!AShooterCharacter::GivePrimalItemWeapon() (0x000007fecfa1856e) + 14 bytes [d:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shootercharacter.cpp:1037]
UE4Editor-Engine.dll!UnknownFunction (0x000007feda2ffa2c) + 0 bytes [UnknownFile:0]
UE4Editor-Engine.dll!UnknownFunction (0x000007feda36c835) + 0 bytes [UnknownFile:0]
UE4Editor-Engine.dll!UnknownFunction (0x000007fed9f85153) + 0 bytes [UnknownFile:0]
UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fed80d1282) + 0 bytes [UnknownFile:0]
UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fed85355f6) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x000000013f8294b4) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x000000013f81ed0f) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x000000013f81ed7a) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x000000013f82ab30) + 0 bytes [UnknownFile:0]
UE4Editor.exe!UnknownFunction (0x000000013f82ba69) + 0 bytes [UnknownFile:0]
kernel32.dll!UnknownFunction (0x0000000076f65a4d) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x000000007709b831) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x000000007709b831) + 0 bytes [UnknownFile:0]

After this error appears the Dev Kit closes automatically!

Any suggestions on this behaviour?

Success!! First Step done!

Ok i finally got rid of the Error cause i didn’t use the right blueprint… I managed to get it to work now and the Model is in my Players Hand!

How do i now customize the click event? At the moment my Player is swinging the remote controller around like an axe but i actually want the Remote Code Input Screen to appear… How do i do that?

Can anybody tell me?

Thx in advanced! FyZ1K

bump? sry but i need answers on this

If you want your custom model to behave not like an Axe, you will need custom animations as well.
In particular for the first person arm mesh of the player.

Not sure if the ARK SDK provides these.
For the default UE4 Playermodel, it’s possible to export via .fbx, which gives you the skeleton at least.

Turning it into an animatable rig is the much bigger task.
Belive me, you wouldn’t want to animate every joint manually.

Also i’ve experienced flaws with the import of animated meshes from C4D to UE4, that are caused by the coordinate system conversion.
By default all animations will end up facing the floor unless you set up the axis of your root objects a certain way.

Well, they Do provide the FPV and TPV Skeletal Structures.

As for capturing the player pressing the button while holding the remote to display a UI - you’ll probably have to Blue Print Graph that.

The closest thing I know of that already does this is the PIN PAD. It can open and close doors set to a particular pin.

Sorry for my horrendous delay - but the new version of the ADK wiped out my entire mod, had to recraft it from scratch - 3 times before I reverted to the older version of the ADK.

Hi everyone!

Sorry for the late reply i was busy and i couldn’t get some time to test it all out untill now!

Here is what i figured out recently:

If you go in to your Weapons Blueprint and view the graph tab you can see a list left of all variables wich you can manipulate insite the defaults tab!

I also found out that there is no entry in the remote keypad blueprint wich describes what happens if the user calls the structure to activate/deactivate the doors which i find awkward! Or else i am looking in the wrong place but inside the graph you can add new click events… Right in the node view window i can’t find anything that would help me do achieve my goal… i tried searching with the terms: key, remote, door… it didn’t find me anything…

Any ideas on this?

Thank you all for your responds!

It’s not as simple as that. You need to build the logic yourself.

Also, if you go into the graph of an object and it’s blank but it has some-what complex functions, it is blocked. A lot, especially with graphs, is still hidden from us and at the same time a lot of the games code would be handled by C++ (the source) which is hidden even further away and which we’ll never see.

-WM

True that Macabre.

Will this happen in Ark Dev Kit or in another IDE? I know a little about C++

So in other words, the option which i am seeking through is not available in the dev kit or at least available with high complex graphing to kinda “rebuild” the door logic? That means i would need my own “Door Actor” Keypad Actor and so on…

If i get this right i think it’s very pitty…

There are mods out there that you interact with to bring up a custom GUI (the Stargat teleporter comes to mind.) Someone’s figured it out, surely we can too :wink:

Wouldn’t the c4 detonator or the transponder gps be a better item to use as a base for something like this since the animation is the hand pressing a button and on the transponder there is the “set radio frequency” ui already in place?