Download

Question about X mark on spotlight while creating blueprint, also no event creation for nodes

Hey guys.

I just recently started learning unreal engine 4.

The first guide i covered was intro to ue4, the second guide was introduction to blueprints.

While watching the blueprint guy, i followed what the guy was doing in the video in my own editor, and could successfully create a blueprint.

But now when i’m trying to do the same thing again, ie creating a blueprint that has a spotlight, there is an “X” mark on the light in the viewport part of the blueprint window.

Also, when i am selecting the components like triggerbox and spotlight, and when i right click on the event graph, i get no option to create events for them, even though i literallly did that 2 days ago.

So what’s going on?

https://i.sli.mg/4ngkCC.png

I had posted this in the rendering section, but it seems to be a ghost town, also i thought it would be more appropriate here.

You can have 4 overlapping stationary lights at a time. The red marker indicates a warning, this light is now casting dynamic shadow.

Have a look here for more info:

You can set light mobility on the right hand side once you’ve selected your spotlight on the left.
More info here:

Regarding this:
Also, when i am selecting the components like triggerbox and spotlight, and when i right click on the event graph, i get no option to create events for them, even though i literallly did that 2 days ago.

Once you’ve placed your objects in the Level Blueprint, you can right click Level Blueprint’s Event Graph and add the references. (I’ve assumed that’s what you’re trying to do.)

But i had not placed even a single light into the level, except the skylight that is present by default in the “Third Person Example” map.

Also, i first used the “Create Blueprint class”, under “Basic Asset”, and then chose “Actor”.
Then i added the “lamp_wall” object, dragged it onto “DefaultSceneRoot” to make it the new root, put in a spot light, and then put in a box trigger.
Still i was not able to create an even when i clicked on the triggerbox in the components panel and right clicked on the event graph.

This image does not contain the box trigger because this was my 3rd or 4th try.

What confuses me is that i was able to do it successfully when i was following the tutorial videos.

Can you provide some more insight?

Just to get it straight. You have placed no objects in your scene. When you hit Play, you can see none of you lights?

If you switch to the Untitled tab in the upper left, you should be able to access World Outliner that list everything that’s currently spawned in the level.

I was working in the “Third Person Example” map.

However, i will go check out the world outliner to list out all objects as you suggested.

I’ll post images of every step.

First step, opening third person example map:-

https://i.sli.mg/q7KT7V.png

Second step, creating a blueprint class under basic asset, then selecting “Actor”:-

https://i.sli.mg/gy4kjG.png

Third step, dragging a lamp prop to the blueprint components, then dragging it onto DefaultSceneRoot to make it root:-

https://i.sli.mg/NsIagx.png

Fourth step, adding a spotlight into the components:-

https://i.sli.mg/gFvrZr.png

Fifth step, hit a wall because X on spotlight:-

https://i.sli.mg/vaH92T.png

Sixth step, checking the world outliner for other lights.There are three light related stuff ie LightMassImportanceVolume, LightSource and SkyLight:-

https://i.sli.mg/JnUFsG.png

So what am i doing wrong??

I didn’t even try to create nodes since i want to solve this problem first, then move on to the next one.

You need Compile

https://i.sli.mg/m67cKk.png

Open Message Log: Window → Developer → Message Log
Hit Play and see if you get any warnings/errors, especially in the Lighting Results.

“Lighting needs to be rebuilt, 5 unbuilt objects”

But this message has always occured, both in the video tutorial guy’s editor and in my own editor.

However, that didn’t prevent me from creating a blueprint with lights and using event nodes earlier.

Also, i opened the log, here’s the message:-

https://i.sli.mg/ZxmyWN.png

Also, the lighting unbuilt error message only occurs when i place any lights into the level.
Here, i had not placed any and had directly gone to work on the blueprint, so i ran the default third person map.

Hm, your spotlight is a child actor (judging by the icon). Try deleting it and just add a Spotlight Component.

Hey everynone, it worked!!!

I have been meaning to reply since a long time, but for the last 15 hours or so i had no internet!!

Really appreciate it.

And thank you to everyone else too who tried to help!!

The solution is not to drag from the main window to the blueprint window, but to use the add component button.Although the previous method worked for me before, i won’t waste more time on it.

Atleast until i have some more idea about child components.